Single Turbo Discussion Area for discussing single turbo RX-7's.

A Hose Or A Cap Or Something Blew..help

Old 03-06-2005, 02:31 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2003
Location: Los Angeles
Posts: 11
Default

I need some help. I was driving and I'm not sure what PSI i was at, it couldn't have been that high but what happened was I notice a sudden loss in RPM when I slowed down. The engine would idle very roughly and was on it's way to shutting off. So what I did i just dropped the clutch and gave it enough gas to stay alive until I reached my location. This has happpened before; While I was tuning the car and went for a test drive to see if the settings were fine I accelerated and ran some boost and I blew a hose off and so I lost air pressure so we just plugged it up and it ran fine. That plug is still there and undisturbed to this day it's done fine. So what I'm asking is, What could it possibly be, if it's another hose or cap which one's are prone to blow easily so I can fix that problem. I'm in quite a rush to fix this problem.



Thanks everyone.
lazymatt7 is offline  
Old 03-06-2005, 04:16 PM
  #2  
Senior Member
 
Join Date: Nov 2001
Location: NJ
Posts: 4,981
Default

check the hose for the map/baro sensor. That one usually pops off causing the car to run like ***. Map/baro is bolted to firewall by throttle body
turbovr6 is offline  
Old 03-07-2005, 12:35 PM
  #3  
Senior Member
 
Join Date: Sep 2002
Location: Alexandria Va
Posts: 657
Default

Does it still crank even? When you say tuning what exactly were you doing?



If not the map check the compression!
Fe3Boost is offline  
Old 03-07-2005, 02:02 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Nov 2003
Location: Los Angeles
Posts: 11
Default

yup, it still cranks. Hope it's not the compression being a brand new remanufactured engine
lazymatt7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Wankelteer
2nd Generation Specific
2
06-01-2004 12:12 PM
Turbo II FC
2nd Generation Specific
6
03-28-2003 04:54 PM
RotaryNoah
3rd Generation Specific
7
02-25-2003 04:28 PM
boost-t
Insert BS here
2
04-05-2002 01:04 PM
dac
2nd Generation Specific
4
02-11-2002 08:31 AM
Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: A Hose Or A Cap Or Something Blew..help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.