Turbo Leak - NoPistons -Mazda Rx7 & Rx8 Rotary Forum
NoPistons -Mazda Rx7 & Rx8 Rotary Forum


2nd Generation Specific 1986-1992 Discussion

Reply
 
 
 
Thread Tools Search this Thread
Old 03-19-2003, 12:14 PM   #1  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 176
Default

I have a turbo leak, when i bought my car it boosted to 17psi, now it won't go above a bit under 15. I'm not positive why it's doing this. i think it might have to do with a hose that is weak, since when i get on it and get the boost up close to 15, the hose blew off today. I hope that's the only reason i'm not getting 17 psi like i should. but my problem with that is that the piping on the turbo that leads up to the intercooler (top mount) has a sensor in it that is so close to the edge of the piping, its hard to get a good enough hosing around it, any suggestions.



87 rx-7 turbo II, jspec motor series IV (if that matters)

T4 turbo
Daiv Makitsu is offline   Reply With Quote
Old 03-19-2003, 12:47 PM   #2  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 176
Default

ANY FEEDBACK WOULD BE GREAT.
Daiv Makitsu is offline   Reply With Quote
Old 03-19-2003, 12:50 PM   #3  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

sensor? they dont have a sensor in the ic piping stock. you could always move it, or double clamp the hose



mike
j9fd3s is offline   Reply With Quote
Old 03-19-2003, 02:01 PM   #4  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 176
Default

It's not in the piping, its on the turbo itself, the part from the turbo to the ic piping, i don't think its really a sensor its might be just a vacuum hose of some kind
Daiv Makitsu is offline   Reply With Quote
Old 03-19-2003, 03:47 PM   #5  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

hmm thats wierd though cause they have a lip for the ic hoses?



mike
j9fd3s is offline   Reply With Quote
Old 03-19-2003, 05:13 PM   #6  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 176
Default

its not the stock turbo
Daiv Makitsu is offline   Reply With Quote
Old 03-19-2003, 05:15 PM   #7  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Quote:
Originally Posted by Daiv Makitsu' date='Mar 19 2003, 03:13 PM
its not the stock turbo
yeah but that pipe is stock?



mike
j9fd3s is offline   Reply With Quote
Old 03-19-2003, 05:44 PM   #8  
Senior Member
Thread Starter
 
Join Date: Aug 2002
Posts: 176
Default

i dont' think so

i think i just need some heavy duty rubber hose
Daiv Makitsu is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Do I Have A Bad Coolant Leak Or A Good Leak? Shaggy's Dad 1st Generation Specific 1 05-02-2004 08:10 PM
I've Got An Exhaust Leak By The Turbo rmaiersg 2nd Generation Specific 7 04-16-2003 09:26 PM
Oil leak better isamu 1st Generation Specific 3 04-11-2002 12:59 PM
Oil leak LITTLE1126 1st Generation Specific 2 02-04-2002 05:26 AM
Oil leak LITTLE1126 Insert BS here 4 02-04-2002 04:10 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:24 PM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.