Bogging at 3500 13b GXL - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

2nd Generation Specific 1986-1992 Discussion

Bogging at 3500 13b GXL

Reply

 
 
 
Old 10-20-2007, 10:30 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2007
Posts: 9
Default

Hey ya'll, I recently bought a 1986 Rx 7, I am having a issue with what I think is the fuel system. It seems to bog whenever I stab it around 3-3.5k RPM's. Also it runs extremely lean. If I roll into the throttle, it will let me rev past 3.5k if not and I put my foot to the floor it bog's. I think its the secondarys, but I haven't pulled them off to check. I was wondering if anyone else had had a similar issue and what they did to correct it, any help is welcomed help thanks in advance, Deviant.
DeviantMotors is offline  
Reply With Quote
Old 10-21-2007, 09:28 AM
  #2  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Agree, secondaries not working.
RONIN FC is offline  
Reply With Quote
Old 10-21-2007, 04:25 PM
  #3  
Junior Member
 
Join Date: Aug 2007
Posts: 11
Default

Yea one of my secondary's wasn't plugged in and my car would bog too. So look into that.
GTU'd is offline  
Reply With Quote
Old 10-21-2007, 04:39 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Oct 2007
Posts: 9
Default

I think I am confused on which injectors are secondary and which are primary. Is it the first to mix with the air, or the first to get fuel? Anyway, I pulled the injectors all out and I will have to bench test them at school on Monday Ill post pics later tonight when I figure out how.



Deviant.
DeviantMotors is offline  
Reply With Quote
Old 10-21-2007, 05:25 PM
  #5  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Secondaries are the ones in the manifold.
RONIN FC is offline  
Reply With Quote
Old 10-21-2007, 05:35 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Oct 2007
Posts: 9
Default

Originally Posted by RONIN FC' post='885982' date='Oct 21 2007, 02:25 PM
Secondaries are the ones in the manifold.




Oh ok, ya when I pulled the injector out of the fuel rail I got a gas bath like there was a crap load of pressure on the injector.
DeviantMotors is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fc3s4utnv
RX-7 & RX-8 For Sale
2
06-19-2009 10:23 AM
billyjp2
2nd Generation Specific
1
03-24-2007 09:19 AM
deltaflyer2010
2nd Generation Specific
4
10-15-2005 08:37 PM
Mabii
1st Generation Specific
1
04-29-2005 02:15 PM
joemommaaa
RX-7 & RX-8 For Sale
0
03-19-2002 09:16 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread