HELP Microtech LT10 13B Rx7 Wont start!! - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

ECU Discussions Area for Haltech, Power FC, MOTEC and other ECUs

HELP Microtech LT10 13B Rx7 Wont start!!

Old 07-11-2012, 10:33 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2012
Posts: 6
Default HELP Microtech LT10 13B Rx7 Wont start!!

hey guys im in need of some help. my fd does not want to start. the microtech is wired up correctly im sure. yellow light flashes when i crank and green is always on indicating power. the red light flashes SOMETIMES when i crank but not all the time. its an error code screen 33? Tha car struggles to start and almost does but it just wont. took off the spark plugs and 2 of em were wet (fuel) im guessing its flooding? Smells like alot of fuel under the hood. the car started fiune before but we left it sitting for about 6 months. Like i said it struggles to start and almost does but it just wont. Any ideas guys??
FD_FTW is offline  
Old 07-12-2012, 11:15 AM
  #2  
Member
 
Join Date: Jul 2011
Location: Kentucky
Posts: 79
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

Probably just flooded. Take out your EGI relay, crank it for 5 seconds, put the relay back in and try again.

You may need to do this a couple times but mine did this with a stock ECU. Took about 30 minutes of going back and forth with it to finally get it to fire and now it's usually fine.

Probably a good idea to get a fuel cut off switch. That way you can keep it from flooding regularly.
leetfade is offline  
Old 07-12-2012, 01:28 PM
  #3  
Junior Member
 
Join Date: Jun 2002
Posts: 14
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

if its been sitting for a long time do an old school trick we used in el barrio all the time. Since you are fuel injected take a siringe full of oil, take one spark plug out per rotor since you are fuel injected and sqirt it thru the hole. That will make compression way easier. If you were carburated pur some thru the butterflies
REBELDE is offline  
Old 07-12-2012, 03:27 PM
  #4  
Member
 
Join Date: Jul 2011
Location: Kentucky
Posts: 79
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

I actually tried that and it didn't work for me. I had to do the EGI relay trick. Every car is different, though!
leetfade is offline  
Old 07-12-2012, 05:17 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Jun 2012
Posts: 6
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

Originally Posted by leetfade View Post
Probably just flooded. Take out your EGI relay, crank it for 5 seconds, put the relay back in and try again.

You may need to do this a couple times but mine did this with a stock ECU. Took about 30 minutes of going back and forth with it to finally get it to fire and now it's usually fine.

Probably a good idea to get a fuel cut off switch. That way you can keep it from flooding regularly.
ill try that right now actually thanks man!
FD_FTW is offline  
Old 07-13-2012, 01:33 AM
  #6  
Member
 
Join Date: Dec 2011
Location: miami
Posts: 70
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

im sure is just the tune. play with the water map . no need to do all that oil crap.
flacorotary is offline  
Old 07-16-2012, 09:39 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Jun 2012
Posts: 6
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

doesnt the microtech come with a stock tune for the 13b fd? it still has stock primaries and secondaries.
FD_FTW is offline  
Old 07-16-2012, 10:59 PM
  #8  
Member
 
Join Date: Dec 2011
Location: miami
Posts: 70
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

is a tune just for start up . after that you have to fix up the tune. driving on the map that comes with is not recommended
flacorotary is offline  
Old 08-28-2012, 07:41 PM
  #9  
Junior Member
 
Join Date: Aug 2012
Posts: 10
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

if the red light comes on it refers to references and home on the hand controller i just would send it back have them run some test and see what they say. if they say its good check ground were your micro tech is hooked up sometimes it comes with a mat that u put it on sometimes removing that gets rid of the code and then make sure to clear the block of stagnate fuel and try starting it.
boostaholic is offline  
Old 11-27-2012, 05:00 AM
  #10  
Junior Member
 
Join Date: Nov 2012
Posts: 6
Default Re: HELP Microtech LT10 13B Rx7 Wont start!!

You are fuel infused take a siring full of oil, take one start attachment out for each rotor inasmuch as you are fuel infused and squirt it thru the hole.
Jackstom is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kuhnke
RX-7 & RX-8 Parts For Sale & Wanted
1
06-01-2008 03:33 AM
sen2two
ECU Discussions
0
08-06-2006 06:59 AM
kojidean
2nd Generation Specific
5
12-04-2005 01:24 AM
rx7_gxl86
2nd Generation Specific
4
03-04-2003 06:23 PM
Squirrel
2nd Generation Specific
3
10-08-2001 08:42 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: HELP Microtech LT10 13B Rx7 Wont start!!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.