2nd Generation Specific 1986-1992 Discussion

Possible Problem With Diff Mounts?

Old 01-17-2004, 04:41 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2003
Posts: 157
Default

Well whenever I let off or get on the gas my car sort of jerks. I wasn't sure, but to me it felt like either a differential mount was bad. The car was dead when I bought it. I rebuilt the engine a few months back, but we didn't do anything to the rear-end but change the fluid. So that's why I think it might be the diff mount. I drove it with a friend in the car last week or so, and he said it felt like the throttle cable was too tight or something. Like the throttle was slamming shut or whatever I guess. That didn't really seem right to me though. Any ideas? How much am I looking at to replace the front diff. mount if that's what it is? Thanks.



-Tristan
ryosuke_fc is offline  
Old 01-17-2004, 05:06 PM
  #2  
Senior Member
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

You should give the front mount a closer look. The rubber usually tears sooner or later..
ColinRX7 is offline  
Old 01-17-2004, 11:21 PM
  #3  
Senior Member
 
Join Date: Apr 2002
Location: NASA/JSC - Clear Lake, TX
Posts: 870
Default

a broken diff mount sounds like a "clunk" in the rear every time you get hard on the gas. you will know it, it sounds broken, and loud.
RX7Aggie is offline  
Old 01-18-2004, 12:39 AM
  #4  
Senior Member
Thread Starter
 
Join Date: Aug 2003
Posts: 157
Default

Okay hmmm maybe it's not the mount then. I don't hear a loud noise. I just feel the car jerk. I'll try to take a closer look at it tomorrow before I go to work if I have time. I might not get to it till tuesday though.
ryosuke_fc is offline  
Old 01-18-2004, 12:40 AM
  #5  
Senior Member
 
Join Date: Dec 2003
Posts: 203
Default

check the tps and the dashpot.
scathcart is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ALNY93R1
RX-7 & RX-8 Parts For Sale & Wanted
1
10-31-2006 05:26 PM
Cheers!
2nd Generation Specific
26
06-03-2005 07:57 PM
jackdhammer
3rd Generation Specific
3
06-15-2003 09:03 AM
ILUVMY88CABRIO
2nd Generation Specific
3
03-15-2003 10:20 AM
FCmaniac
2nd Generation Specific
5
09-02-2002 11:46 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Possible Problem With Diff Mounts?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.