2nd Generation Specific 1986-1992 Discussion

No fuel getting past fuel pressure regulator

Old 08-25-2013, 01:13 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2011
Location: Oklahoma
Posts: 3
Default No fuel getting past fuel pressure regulator

Im trying to bring an 87 tii back to life and its fighting me. Put in a donor motor from another tii, took it apart on my own without much knowledge on them. Back together and in car. I cannot get fuel into the fuel rail, any ideas on why the fuel pressure regulator would be bad(i have a new one on there). Could my fuel pressure be too low (new walbro and seems ok on pressure to the rail). Could there be a vacuum issue? Is there a good way to check the pressure regulator to see if its functioning?
1987 tii with s4 non original engine (amateur rebuilt)
Haltech sprint ecu
Walbro 255 fuel pump
Autozone fuel pressure regulator and fuel filter
Its in north east oklahoma
Wtbehm is offline  
Old 08-25-2013, 11:36 AM
  #2  
Junior Member
Thread Starter
 
Join Date: Jun 2011
Location: Oklahoma
Posts: 3
Default

May have answered my own question. Problem was me.
Wtbehm is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ioTus
2nd Generation Specific
6
11-11-2003 02:48 PM
turborotor
2nd Generation Specific
6
06-19-2003 12:09 AM
blaze08
3rd Generation Specific
10
05-05-2003 11:40 PM
1Revvin7
2nd Generation Specific
20
08-25-2002 11:46 AM
OKIERX-7
Performance Mods
26
07-05-2002 07:59 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: No fuel getting past fuel pressure regulator


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.