2nd Generation Specific 1986-1992 Discussion

Na S5 Help

Old 06-07-2004, 04:34 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 10
Thumbs up

Well, after working on the car today, I think the cars owner got a bad deal. I feel bad for him.

Anyway, instead of an S5 motor as he thought, someone installed an S4 motor *with* an S5 throttle body (hence no OMP rod attachment). There is NO air pump and someone rigged all sorts of **** just to get the car strted and it runs like **** . There is no power and bogs when you floor it (ECU limp mode due to no OMP connection).

The temp sensor connector was a spade connector and the block sender was a bullet type so another clue it's an S4 motor.

So, from what's written above, what do I need to get to get it to run properly? I am naive about NA S5 cars.

I know I need an S5 front cover with OMP and air pump. Could I change the ECU to an S4 as a temporary fix to disable the limp mode? ****, I'm not sure if the ECU pins are the same on S4 and S5.
boosted1205 is offline  
Old 06-07-2004, 05:02 AM
  #2  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 10
Default

Ack...nevermind. ECU pins are different.
boosted1205 is offline  
Old 06-07-2004, 09:00 AM
  #3  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

on the temp sensor you can build a little spade to bullet adaptor, the sensors read the same.



you need to plug in the metering pump, electrically to make the codes go away, and you can add the mop lever to an s5 tb
j9fd3s is offline  
Old 06-07-2004, 11:35 AM
  #4  
Super Moderator
 
mazdaspeed7's Avatar
 
Join Date: Sep 2002
Location: Savannah, Ga
Posts: 2,763
Default

Put a S5 front cover on it with a working S5 OMP. I have both for sale, PM me if you need them.
mazdaspeed7 is offline  
Old 06-08-2004, 01:46 AM
  #5  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 10
Default

Is the oil line from an S4 and S5 the same ro do I need to get a S5 oil line as well?
boosted1205 is offline  
Old 06-08-2004, 05:28 AM
  #6  
Super Moderator
 
mazdaspeed7's Avatar
 
Join Date: Sep 2002
Location: Savannah, Ga
Posts: 2,763
Default

The lines should be the same, or at least close enough to work.
mazdaspeed7 is offline  
Old 06-08-2004, 04:06 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 10
Default

Thanks. At least that'll help him. For now I have the OMP rod zip tied up for him to have some oil injection.
boosted1205 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fcrotornut
2nd Generation Specific
27
04-18-2007 04:31 PM
up&coming
2nd Generation Specific
7
10-07-2003 09:17 PM
mockujin
2nd Generation Specific
1
06-15-2003 11:53 PM
racerxtreme7
Interior, Exterior, Audio Mods
11
02-08-2003 10:17 AM
leoiu69
2nd Generation Specific
4
03-24-2002 08:27 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Na S5 Help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.