2nd Generation Specific 1986-1992 Discussion

my climate controll stoped working

Old 02-01-2006, 10:33 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Mar 2005
Location: denver
Posts: 271
Default

all the switches were working, then one day i went to turn the heater on and the fan will not kick on. what would make this happen? it makes a clicking noise when u turn it from off and move it a little, and then clicks again once it reaches the end, but it never blows....what fuse if the one for it?
ryderx is offline  
Old 02-01-2006, 10:37 PM
  #2  
Administrator
 
Join Date: Jul 2001
Location: Stuart, FL
Posts: 24,412
Default

logicon crapped out on you more then likely.



You can get them rebuilt on ebay or pick up a used one off of someone.
phinsup is offline  
Old 02-01-2006, 10:44 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Mar 2005
Location: denver
Posts: 271
Default

what is that, where is it, what does it look like? thanks
ryderx is offline  
Old 02-01-2006, 10:46 PM
  #4  
Administrator
 
Join Date: Jul 2001
Location: Stuart, FL
Posts: 24,412
Default

its the entire unit that you use to control your heat, ac, fan, vents, etc... the one with the lights on it above your radio.
phinsup is offline  
Old 02-01-2006, 10:57 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Mar 2005
Location: denver
Posts: 271
Default

anyone thats parting out a car have one for sale?
ryderx is offline  
Old 02-02-2006, 05:36 AM
  #6  
Senior Member
 
Join Date: Apr 2004
Location: Kincardine, Ontario Canada yeah Canada bitches
Posts: 1,068
Default

Those things are a PITA to get out, but sounds just like the Logicon, I WOULD TAKE IT OUT AND RESOLDER MYSELF. sorry about the caps.
nismo convert is offline  
Old 02-02-2006, 10:05 AM
  #7  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

might wanna check fuses real quick too
j9fd3s is offline  
Old 02-04-2006, 12:06 AM
  #8  
Senior Member
Thread Starter
 
Join Date: Mar 2005
Location: denver
Posts: 271
Default

well thats not the problem, im going to pull out the fan 2maro and see if thats any good.
ryderx is offline  
Old 02-05-2006, 10:30 PM
  #9  
Senior Member
Thread Starter
 
Join Date: Mar 2005
Location: denver
Posts: 271
Default

ok so i pluged the fan up to my battery charger and it works. if i put it on max and plug it in it starts spining, then once i click it off max it stops. and will not start again till i unplug it and put it on max and turn it back on. whats the prob?
ryderx is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ryderx
2nd Generation Specific
4
03-14-2006 10:02 AM
ryderx
2nd Generation Specific
1
05-26-2005 06:27 AM
full-cruise
2nd Generation Specific
9
05-24-2005 12:10 PM
redfusion
3rd Generation Specific
1
04-18-2003 04:42 PM
Rob x-7
2nd Generation Specific
5
09-28-2002 02:51 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: my climate controll stoped working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.