2nd Generation Specific 1986-1992 Discussion

engine help

Old 12-29-2005, 07:54 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Sep 2003
Posts: 186
Default

Look like my turbo went bad again. White smoke every where. The only confusion I have is the amouint of oil dripping and spraying into the engine bay. The oils leaks from what looks like...the transmission housing and the up spray....I think is from the oil hitting the flywheel. The car turns on like a match but the oil spewing has me worried. Can the rear plate crack anyplace else besides the common oil filter area if it did detonate? Oh yeah once I drive it normal, It drives fine, once it starts to boost it really holds back. I hope it's just the turbo.....any ideas or suggestions



Thanx in advance
rotary632 is offline  
Old 12-29-2005, 10:56 PM
  #2  
Junior Member
 
Join Date: Dec 2005
Location: Marlton, NJ
Posts: 4
Default

Sounds all to familiar.

I'm hoping the same thing (the turbo) is causing the white smoke as well.

I don't think this is your oil leak but i had the oilpressure sending unit crack

at the threads (while driving) and it was puting out quite a bit of oil.

Good luck and just keep pouring in oil till its fixed
V41kyr is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
fcrotornut
2nd Generation Specific
27
04-18-2007 04:31 PM
up&coming
2nd Generation Specific
7
10-07-2003 09:17 PM
ROTARYROCKET7
Insert BS here
4
06-05-2003 01:22 AM
chase78
RX-7 & RX-8 For Sale
0
11-25-2002 05:37 PM
tda79
Engine Swaps
4
04-23-2002 04:19 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: engine help


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.