2nd Generation Specific 1986-1992 Discussion

90 idle problem with video

Old 04-07-2012, 02:55 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2012
Posts: 2
Default 90 idle problem with video

Hey guys. I bought this 7 in late january. Stock na motor. Previous owner removed all emissions including the bac valve. Car at one time had a tii motor in it. Not too sure if that might have something to do with it.

Heres the problem. It wont idle below 1k rpm. If it drops any lower, it just bounces between 400 and 800 rpm. If you give it gas, it'll raise back up to 1k but if you add any electrical load it'll drop again and just bounce or just die. The car also requires a little bit of throttle to start. Again, not sure if that has anything to do with it but.

I've added a bac valve that seems to test out ok but dont have another car to try it on. It doesnt seem to help.

The timing is also off. When under the timing light, the timing mark on the "crank" is under the waterpump. I've tried to adjust the cas but i cant get it to the pointer before i hit the edge of the adjustment. The car is also missing under idle which i believe is related to the timing.

Ive tried to do a compression check on it but im not too rotary savy. I "think" it tested out ok but not sure. The car runs great. Pulls all the way to redline, good torque, no smoke, etc.

Checked for vacuum leaks till i was blue in the face. I replaced uim to plenum and uim to lim gaskets, injector o-rings and seals, all lines for omp were replaced, and all new vacuum caps on all nipples. Ive gone through many a can of carb cleaner trying to find any more and nothing.

Adjusted the tps multiple times. Set it to 1vdc at the computer.

Crappy video:

http://youtu.be/A-sZwhtE32A

Ive been searching since i bought this car in january but I cant find any more info on this. Ive run out of things to check and need help. I want to love this car but its just been a pain so far.

Thanks
Michael
slowbeemer is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Dev
2nd Generation Specific
5
05-29-2006 04:57 PM
z-beater
Northwest
15
05-25-2006 09:21 PM
z-beater
Northwest
16
05-15-2006 11:20 AM
Welsh Dan
3rd Generation Specific
3
12-17-2005 11:45 AM
Booztd 3
3rd Generation Specific
1
08-01-2005 07:16 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 90 idle problem with video


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.