2nd Generation Specific 1986-1992 Discussion

88 convert, start sometimes, white smoke?! help!

Old 10-24-2006, 02:56 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2006
Posts: 4
Default

ive got a 1988 rx7 convertible, 5 spd, 118k miles. i bought the car a month ago with many mods, including a 3rd gen alternator which blewmany fuses, replaced fuses but ac/heater doesnt turn on even after replacing temp control unit and power top stopped working, but now recently car starts when cold after like 5-7 mins of cranking but if i run it anywhere, eventhough all gauges are normal and the car does perfect when running, it wont start again if i shut it off, it just keeps turning as big clouds of white smoke come out of the exhaust. if i take out the plugs and clean or replace them it starts again or if it sits for about a day, but i cant figure out why the plugs keep fouling or getting wet!!?? any advise would be greatly appreciated.



the car is in the dealership right now so they can check it out but its been 2 days since my appointment and they still havent even looked at it, and if i can fix it i dont wana have to pay them to do it..lol, thanks!
foremanatv is offline  
Old 10-24-2006, 03:39 PM
  #2  
Senior Member
 
Join Date: May 2004
Location: Minnesota!
Posts: 452
Default

replace your plugs, and check your fuel system, sounds like its running rich as hell
rootbeerdragon is offline  
Old 10-25-2006, 08:03 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Oct 2006
Posts: 4
Default

ah ha!! i found the problem, the shop just called me, the coolant temp sensor was broken which caused it not to start and they fixed it so it starts fine, they retapped the alternator, and the electrical prolem just blew all the fuses but when they replaced them they all work but they said that if they use them for too long it smokes out of the dash and will blow the fuses again!! this could be a problem, does anyone know what this could be??



also i am in upper delaware and i need to get the carpet redone, ive torn it out but i need to get some put in, anyone know of a place?
foremanatv is offline  
Old 10-25-2006, 08:04 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Oct 2006
Posts: 4
Default

Originally Posted by foremanatv' post='842386' date='Oct 25 2006, 09:03 AM

ah ha!! i found the problem, the shop just called me, the coolant temp sensor was broken which caused it not to start and they fixed it so it starts fine, they retapped the alternator, and the electrical prolem just blew all the fuses but when they replaced them they all work but they said that if they use them for too long it smokes out of the dash and will blow the fuses again!! this could be a problem, does anyone know what this could be??



also i am in upper delaware and i need to get the carpet redone, ive torn it out but i need to get some put in, anyone know of a place?
foremanatv is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
christina
2nd Generation Specific
0
06-25-2009 09:57 PM
Dramon_Killer
2nd Generation Specific
14
12-17-2003 10:35 PM
88tii
2nd Generation Specific
3
08-07-2003 09:43 PM
1988RedT2
2nd Generation Specific
16
02-15-2003 11:47 PM
88Turbo
2nd Generation Specific
8
12-26-2002 09:38 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: 88 convert, start sometimes, white smoke?! help!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.