2nd Generation Specific 1986-1992 Discussion

Well I think she finally died today

Old 03-28-2006, 03:54 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Well, the FC might have died for good today, it was running great on the way to work, hauling *** no problems, it was raining so I couldnt get on it too much, but I came out of work, drove it home and it seemed to be ok, drove home boosting fine. I parked it at my girlfriends place for about an hour or so and when I came out it ran like ****, just like ****, not boosting worth a ****, the sound is incredibly nasty sounding, it sounds NA, under boost I get a nasty noise that sounds like its comming from the turbo, but I checked the compressor side and it seems fine, a little play but nothing worth writing home about.



I crawled under my car to check out the exhaust manifold, and it seems fine, I really dont have time to tear the bitch down to the exhaust manifold to check, i get a light tick, nothing as bad as it used to be before I tightened down the DP and exhaust manifold, weeks ago. It just randomly started ticking, and has gone down hill from there. Really banging my head against the wall here, I mean. WOT it sounds NA like the turbo isnt boosting at all, i was hitting barely 7 psi earlier. Boost gauge shows 0 vac at idle, was showing between 600 and 900 vac at idle earlier today.....



Any tips would be appreciated....
tancred is offline  
Old 03-28-2006, 04:28 PM
  #2  
Senior Member
 
Join Date: May 2005
Posts: 959
Default

Stock manifold? Maybe its cracked?



How's the idle? No fluids under the car?



My guess would be the exhaust turbine wheel/exhaust manifold let go..the are prone to cracking after a while anyways.



If you pull that off and it seems ok, perhaps you have lost your rear rotor..does the car feel very underpowered? Not like, "i have no boost" more like loses acceleration up hills, etc...?
One320B is offline  
Old 03-28-2006, 05:17 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

1. SS Autochrome S4 Stock Turbo Manifold HPC Coated

2. Not cracked from what I can see.

3. Idle is stable at any RPM i want it to be at.

4. No fluids under the car.

5. Found out my MSD came undone AGAIN! So might be fixed with that....



6. Doesnt feel under powered, feels NA. Seeing 0 vac at idle, and when I do boost it makes the needle go further into vac not into boost.



Also, alternator clip wont stay in, so i have to keep jumping the ******...
tancred is offline  
Old 03-28-2006, 05:59 PM
  #4  
Senior Member
 
Join Date: May 2003
Location: watertown wisconsin
Posts: 1,331
Default

you sure you just didnt pop off a intercooler pipe? something similar to that happend to my fc, turns out the ic pipe blew off. anyways my car was also showing no vac or boost and sounded differnt when it was like that.
fc3sboy1 is offline  
Old 03-28-2006, 06:07 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Nope not a IC pipe, I havent tested it with the MSD plugged back in, because im waiting for a jump....
tancred is offline  
Old 03-29-2006, 10:14 AM
  #6  
Senior Member
 
Join Date: May 2005
Posts: 959
Default

If you have ignition breakup, that can affect your boost...but you should still be boosting a little...



I'd check that SS autochrome mani if the car continues to run bad, they arent the greatest and are known to crack..
One320B is offline  
Old 03-29-2006, 03:04 PM
  #7  
Senior Member
 
Join Date: Dec 2002
Location: Wayne, NJ
Posts: 4,838
Default

if the msd comes unplugged or the spliced wires are loose youll have problems.



even in an n/a with acceleration you make less vacuum. so id say youre gauge is wrong or broken, hell some n/a's even see positive pressure due to the manifold design (yes i know, technically vacuuum is pressure bla bla bla).



alternator clip falling off....how far are you driving without the alternator? that much of a load placed only on the battery will kill a battery in no time.



also...an n/a has less power then a t2. so to say it doesnt feel like a loss of power it just feels like an n/a...well it doesnt make sense.



they major thing with modifying these cars is to first make everything stock work fine, no problems for a while. then one at a time add a mod...drive around make sure no problems etc. thats how i did it before i went ***** out and shredded the engine bay .



kevin.
teknics is offline  
Old 03-29-2006, 04:47 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Well its the turbo for sure, I mean that bitch is literally chewing at the hot side, the turbine is f00ked I can tell even before i open it because I can hear it gnawing at the housing....drives like a charm until I try to get out of boost then I get the nastiest exhaust sound, patchy boosting, and a whole slew of WTF is that rattling noise from the turbo.... I am almost 99% sure I am going to find mising turbine fins....
tancred is offline  
Old 03-29-2006, 04:47 PM
  #9  
Senior Member
 
Join Date: May 2005
Posts: 959
Default

Bah... i went all out, lol....
One320B is offline  
Old 03-29-2006, 04:50 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

I fixed the MSD but its still acting bad...I am also reading 0 vac when I accelerate she flies down to WAY strong vac and then flings back to like 7 lbs, but the whole time it sounds like someone has an electric turkey cutter inside my engine bay cutting my turbo...LOL
tancred is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RevRex-7
2nd Generation Specific
3
04-01-2005 12:17 PM
CrashFactory
Insert BS here
0
06-11-2004 01:02 AM
9BASE3
3rd Generation Specific
76
02-23-2004 01:00 AM
drew
Insert BS here
38
12-29-2003 11:26 PM
RotaryPupil
Engine Swaps
2
06-17-2003 11:11 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Well I think she finally died today


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.