2nd Generation Specific 1986-1992 Discussion

Still Having Problems

Old 05-14-2004, 09:44 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2004
Posts: 8
Default

ok on my 86 GXL my coolent migrates from the cooling system to the overflow bottle and the low coolent light comes on, its pissing me off, im going to diconnect the buzzer today and get yet ANOTHER new radiator cap, but i have also replaced the hose that goes from the rad. cap to the over fill bottle, my senor trouble shoots good, wtf is going on? is there something in the cumbustion area thats blowing air in there? help me out
ar_t-bone is offline  
Old 05-14-2004, 10:59 AM
  #2  
Senior Member
 
Join Date: Mar 2004
Posts: 172
Default

You might want to have a CO2 test performed on the coolant. If it fails the motor will more than likely need a coolant seal (rebuild time). Then again, it could just be a weak spring in a tired radiator cap - which is a lot better problem to have
marcus7 is offline  
Old 05-14-2004, 02:35 PM
  #3  
Senior Member
 
Join Date: Sep 2003
Location: San Diego
Posts: 595
Default

yep sounds like re build time
SPD Racing FC is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
relisys190
2nd Generation Specific
7
05-09-2003 09:30 PM
relisys190
2nd Generation Specific
3
04-22-2003 07:01 AM
vancouverrx7
Performance Mods
4
01-07-2003 02:51 PM
Rotaryman88
Insert BS here
7
12-03-2001 09:01 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Still Having Problems


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.