2nd Generation Specific 1986-1992 Discussion

On startup, tach revs to 7k, beeps, then shuts off

Old 07-25-2011, 11:43 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2011
Location: Bay Area
Posts: 1
Default

Hey guys, I have a base model 86 that has recently run into this problem. This happens about once every 5-6 startups. It has even happened while the car was in motion.



I think it might be an electrical short somewhere because this started happening after I cleaned the engine bay with some engine degreaser (and being the lazy idiot that I am, I didn't bother to cover the electrical wiring prior to spraying it down).



Another funky thing that has been happening is that my dome light stopped working. If I set it to "door", the "door ajar" light comes on even if my doors are closed. The "door ajar" light turns off when I switch it to "off" or "on".



Any help would be appreciated. Thanks!
Soundave is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Daviddk
2nd Generation Specific
3
07-10-2007 02:58 AM
Rookie84
2nd Generation Specific
3
03-29-2004 11:22 PM
rotogod
3rd Generation Specific
0
06-29-2003 12:51 PM
LS1 Powered
2nd Generation Specific
4
05-08-2003 06:33 PM
Apollorx7
2nd Generation Specific
11
02-14-2003 12:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: On startup, tach revs to 7k, beeps, then shuts off


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.