2nd Generation Specific 1986-1992 Discussion

Oil Line Blew

Old 03-10-2005, 07:24 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Feb 2003
Location: Miami, Florida
Posts: 1,591
Default

Well it blew and i was driving but did not notice till i got home and parked and saw a trail of oil for about 2 blocks when i got home and parked the buzzer turned on i was like WTF stoped turned off the car and checked the oil it was bone dry. and a puddel of oil under. the car turns on and sounds fine but im worried what could have happened or did i cacth it in time?
RX7 13B 4 UR AZZ is offline  
Old 03-10-2005, 07:38 PM
  #2  
Senior Member
 
Join Date: Nov 2002
Posts: 3,108
Default

Well, can't do much now... just refill and hope for the best
Cheers! is offline  
Old 03-11-2005, 01:29 AM
  #3  
Senior Member
 
Join Date: Jan 2002
Location: San Jose, CA
Posts: 1,145
Default

Fix the hose, slam some oil in it, and keep driving it. Should be ok, Mike ran the racecar out of oil once on Thunderhill raceway. We put fresh oil in it and ran HPDE Group 4, PS1 heats, and the enduro.
cymfc3s is offline  
Old 03-11-2005, 02:19 AM
  #4  
Senior Member
 
Join Date: Jun 2002
Posts: 144
Default

i drove 20 miles once WITHOUT oil in my 88 tii. she turned out fine
RX7ryder is offline  
Old 03-12-2005, 12:54 AM
  #5  
Senior Member
 
Join Date: Jan 2005
Location: Greenwood AR
Posts: 831
Default

But when you go to get a rebuild, things wont be just fine. You will be lucky if some of the bearings havent seized up.



Order yourself some Corksport SS oil lines spend the time to put them on and be carefull for awhile, if everything seems okay, continue to drive like you normally would.
fc3s4utnv is offline  
Old 03-12-2005, 01:11 AM
  #6  
Senior Member
 
Join Date: Jan 2003
Location: union, new jersey
Posts: 8,079
Default

you ever see those commercials where the cars are drained of oil and then ran for long periods of time before seizing?



i hope thats true. cuz the same **** that happened to you happenned to me about a month ago, the car is fine, and there were no flakes or shavings in my oil change or filter (yeah check for those, if you find some, that means bye bye bearings)
FikseRxSeven is offline  
Old 03-12-2005, 06:05 PM
  #7  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Originally Posted by cymfc3s' date='Mar 10 2005, 11:29 PM
Fix the hose, slam some oil in it, and keep driving it. Should be ok, Mike ran the racecar out of oil once on Thunderhill raceway. We put fresh oil in it and ran HPDE Group 4, PS1 heats, and the enduro.



yeah i got to turn 6 and the motor was fine, it came apart later and the bearings were fine too. granted paulie broke EVERYTHING else but hey it didnt starve for oil
j9fd3s is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jimmymotto
2nd Generation Specific
3
05-10-2003 11:16 PM
1Revvin7
2nd Generation Specific
8
12-01-2002 10:04 PM
jspecracer7
Single Turbo Discussion
4
11-23-2002 01:14 PM
Turbo II FC
2nd Generation Specific
4
11-04-2002 11:14 PM
intheburgh
1st Generation Specific
1
04-27-2002 06:18 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Oil Line Blew


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.