2nd Generation Specific 1986-1992 Discussion

Need Help With Shifter Please

Old 06-10-2004, 01:26 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2004
Location: Little Rock AR
Posts: 16
Default

I have a S5 transmission that will be going in my car the next few days.... I hope. I have cleaned out the turret, new oil, Mazdaspeed shortshifter, and new bushings and wave springs.



It still does not center. It has plenty of spring tension to the 5 and reverse gates, but towards the 1 and 2 nothing. I would like to fix this. All of my Mazda transmission pre mid 90s do this. Please help
T72FC is offline  
Old 06-10-2004, 05:27 PM
  #2  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Are you sure its an S5 tranny? They dont usually do that.



Anyway, i wouldnt worry about that. Its common mostly to S4s.

My oppinion is that it isnt worth fixing. Unless you like taking the tranny housings appart.
RONIN FC is offline  
Old 06-10-2004, 05:55 PM
  #3  
Senior Member
 
Join Date: Nov 2003
Location: Hell (Colorado School of Mines)
Posts: 517
Default

Huh, mine(s4) is just the opposite. Tension towards first, no tension towards 5th. I always figured that was normal. It feels fine.
CGeek2k is offline  
Old 06-10-2004, 08:05 PM
  #4  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

the shifter spring is broken, you need to pull the tailshaft housing off to fix it
j9fd3s is offline  
Old 06-10-2004, 08:37 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Jun 2004
Location: Little Rock AR
Posts: 16
Default

My S3 N/A tranny does and so does my S5 N/A tranny.



Anyway, got a part number for me and is the spring the same between N/A and the turbo trannys, I might as well order a few of them, need to fix the Beaters transmission soon anyway.





I don't think the tail shaft will be that hard to remove, the roll pin in the shifter turret looks like its going to be a pain the *** to get out though.





Why couldn't Mazda put that spring back in the turret, like the springs to the 5 and reverse side.





Anyway if anyone can get me a part number, it would help quite a bit, I might even do a write up on this. Ether I have bad luck, or this a common failure.
T72FC is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rotors_motor
2nd Generation Specific
8
07-02-2011 02:54 AM
ChainSawOnSteroids
Rotary Engine Building, Porting & Swaps
8
02-21-2007 10:45 AM
ZeroRX7
RX-7 & RX-8 Parts For Sale & Wanted
2
05-20-2005 03:56 PM
FrostRacing
2nd Generation Specific
24
10-24-2003 10:15 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Need Help With Shifter Please


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.