my first performance mod - NoPistons -Mazda Rx7 & Rx8 Rotary Forum
NoPistons -Mazda Rx7 & Rx8 Rotary Forum


2nd Generation Specific 1986-1992 Discussion

Reply
 
 
 
Thread Tools Search this Thread
Old 08-08-2002, 08:04 PM   #1  
Senior Member
Thread Starter
 
Join Date: Feb 2002
Posts: 509
Default

ok so i order this cone filter off ebay

and it comes in (my filter was blue) so when i took out the stock box i left the AFM? on and just attached the bracket that was on the bottom of the box to the braket that holds the box (the one on the strut tower) i put the filter on the front and bought a breather filter for my air pump and every thing is kewl. as for power i don't notice it really but the car runs smmoother throughout the rev range anyway just letting you guys my elation
The Blue Bomber is offline   Reply With Quote
Old 08-08-2002, 08:06 PM   #2  
Senior Member
 
Join Date: Apr 2002
Location: IL
Posts: 2,930
Default

Do you have an NA or turbo?
pengaru is offline   Reply With Quote
Old 08-08-2002, 08:07 PM   #3  
Member
 
Join Date: Jul 2002
Posts: 50
Default

cool what engine is it?
richrx is offline   Reply With Quote
Old 08-08-2002, 08:15 PM   #4  
Senior Member
Thread Starter
 
Join Date: Feb 2002
Posts: 509
Default

91 n/a
The Blue Bomber is offline   Reply With Quote
Old 08-08-2002, 08:17 PM   #5  
Senior Member
 
Join Date: Apr 2002
Location: IL
Posts: 2,930
Default

hmm, have you tried wiring the aux ports open? The stock airbox is pretty restrictive... although if you have your cat(s) and stock manifold you might not get anything significant from eliminating it. BTW, twist ties do the trick for wiring open the aux ports, just remove

the actuators first (2 10mm nuts each):

pengaru is offline   Reply With Quote
Old 08-08-2002, 08:21 PM   #6  
Senior Member
 
Join Date: Nov 2001
Posts: 664
Default

Aren't the 6 ports are airpump actuated on a series 5? I'd leave those and the VDI alone.
Felix Wankel is offline   Reply With Quote
Old 08-08-2002, 08:23 PM   #7  
Senior Member
 
Join Date: Apr 2002
Location: IL
Posts: 2,930
Default

oh **** yeah, i'm too used to my series 4 nevermind me.
pengaru is offline   Reply With Quote
Old 08-08-2002, 08:27 PM   #8  
Senior Member
 
Join Date: Nov 2001
Posts: 664
Default

Wired open ones worked great on my old S4 GXL
Felix Wankel is offline   Reply With Quote
Old 08-08-2002, 11:21 PM   #9  
Senior Member
 
Join Date: May 2002
Location: Richardson Texas
Posts: 4,326
Default

thats the same one i have
Shane.Trammell is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
First Gen....First Rx7...First RHD SAfreak Meet and Greet 4 08-02-2014 08:48 PM
Performance Mod's JNA 13B 2nd Generation Specific 0 05-23-2010 08:31 PM
First Cadillac CTS-V performance test published trev0006 Other Cars 2 08-27-2008 08:17 AM
The Performance Mod Addiction clumzy 2nd Generation Specific 3 12-21-2001 11:24 PM
Your WORST Performance Mod????? LUV94RX7 Insert BS here 14 11-11-2001 07:30 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.