Magor Drivebility Problems - Page 2 - NoPistons -Mazda Rx7 & Rx8 Rotary Forum
NoPistons -Mazda Rx7 & Rx8 Rotary Forum


2nd Generation Specific 1986-1992 Discussion

Reply
 
 
 
Thread Tools Search this Thread
Old 02-18-2003, 10:14 PM   #11  
Junior Member
Thread Starter
 
Join Date: Feb 2003
Posts: 9
Default

how much compession should it have (psi)?
svo_jon is offline   Reply With Quote
Old 02-18-2003, 10:28 PM   #12  
Senior Member
 
Join Date: Nov 2001
Location: LA, USA
Posts: 1,622
Default

anything below 80psi, is not good



Not having even pulses between rotor phases or rotors is not good.



C
turborotor is offline   Reply With Quote
Old 02-19-2003, 05:30 PM   #13  
Junior Member
Thread Starter
 
Join Date: Feb 2003
Posts: 9
Default

what do you mean by rotor phases? What do I need to know to do a correct compression test on a rotary engine?

thanks
svo_jon is offline   Reply With Quote
Old 02-19-2003, 06:04 PM   #14  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Quote:
Originally Posted by svo_jon' date='Feb 19 2003, 03:30 PM
what do you mean by rotor phases? What do I need to know to do a correct compression test on a rotary engine?

thanks
there are 3 chambers for each spark plug, so you are looking for 3 even bounces on your comression guage. take out or push the schrader valve on the tester



mike
j9fd3s is offline   Reply With Quote
Old 02-20-2003, 09:48 PM   #15  
Junior Member
Thread Starter
 
Join Date: Feb 2003
Posts: 9
Default

so I did a compression test and the second rotor makes only about 40 psi. I guess I found the problem. So this means a rebuild right? Anyone know of a good place to get one on the wet coast/Oregon area? How much should I expect to pay? Any help would be great

thanks
svo_jon is offline   Reply With Quote
Old 02-20-2003, 10:32 PM   #16  
Senior Member
 
Join Date: Nov 2002
Location: Colorado Springs
Posts: 1,679
Default

Quote:
Originally Posted by turborotor' date='Feb 18 2003, 10:32 PM
There is no "check engine" light in 86-88 rx7s cause they use the atari 2600 ecu. Gotta build a 2 led test light for that series.
sorry about that... i've only owned s5's wont happen again sir
Apex13B is offline   Reply With Quote
Old 02-20-2003, 10:33 PM   #17  
Senior Member
 
Join Date: Nov 2002
Location: Colorado Springs
Posts: 1,679
Default

www.pineappleracing.com



they are in portland i think
Apex13B is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
problems problems The Blue Bomber 2nd Generation Specific 8 10-31-2002 04:08 PM
Problems agrillo Insert BS here 15 03-04-2002 02:50 PM
Double posting problems. 13BAce Front Desk 4 01-09-2002 08:27 PM
Carb Problems firstgenjohn Insert BS here 1 12-06-2001 12:30 PM
Anybody else having problems w/ voting.. Rotaryman88 Insert BS here 7 12-03-2001 09:01 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:02 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.