2nd Generation Specific 1986-1992 Discussion

HELP! Please!

Old 01-12-2006, 09:37 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2006
Location: Silverdale Wa.
Posts: 7
Default

Need Help!!!

Description: Over the course of two weeks, dash lights would not light up until after driving about 10 minutes. Then TACH did not work for about two days. Final while starting up last day got a buzzer with no indicator light lit. Tach would not work and after 6 miles I stopped and then made a turn. Car started jerking (like to much gas or not enough) then died after about 1/2 mile. Sat for 20 minutes it started up then went about 5 miles and died totally and would not turn over again. Turn the ignition and it turns but no cranking. Believe it to electrical in nature but I am not a great mechanic. Please advise if possible.



anav711 is offline  
Old 01-13-2006, 02:36 AM
  #2  
Senior Member
 
Join Date: Oct 2001
Location: Marysville WA.
Posts: 1,847
Default

Might want to check the alternator out.
isamu is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SYCO
Rotary Engine Building, Porting & Swaps
2
03-24-2009 11:56 AM
ChainSawOnSteroids
Rotary Engine Building, Porting & Swaps
8
02-21-2007 10:45 AM
FrostRacing
2nd Generation Specific
24
10-24-2003 10:15 AM
bacca
2nd Generation Specific
16
07-15-2003 10:18 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: HELP! Please!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.