2nd Generation Specific 1986-1992 Discussion

Alternator Problem

Old 05-05-2004, 07:38 PM
  #1  
Member
Thread Starter
 
Join Date: Dec 2003
Location: Barksdale AFB, LA
Posts: 94
Default

Well, over the past three weeks, my alternator light has come on when I turn the car on, and usually goes off within 15 or so minutes. I'm thinking about checking some cables first, not really sure where to start though, and then if it still giving me problems, maybe looking into a new(er) unit. btw, it's an '86. Thanks all!
majeskyb is offline  
Old 05-05-2004, 08:48 PM
  #2  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

clean your battery connections first, then the rest of the connections on the alternator
j9fd3s is offline  
Old 05-05-2004, 09:04 PM
  #3  
Member
Thread Starter
 
Join Date: Dec 2003
Location: Barksdale AFB, LA
Posts: 94
Default

Will do, thanks again
majeskyb is offline  
Old 05-05-2004, 09:07 PM
  #4  
Senior Member
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Doesn't hurt to take it somewhere for a battery/output charge test either.
ColinRX7 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
zoo1
3rd Generation Specific
4
05-08-2008 11:40 PM
BigTurbo74
RX-7 & RX-8 Parts For Sale & Wanted
6
11-26-2007 06:09 AM
DJAngelicon
1st Generation Specific
2
05-21-2006 07:34 PM
chompski
1st Generation Specific
4
10-08-2003 01:52 PM
Rotarydragon
2nd Generation Specific
10
02-26-2002 03:06 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Alternator Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.