Vintage Mazda Rotary RX-2, RX-3, RX-4, REPU, etc....

'74 rx3 tach not working.

Old 05-21-2012, 06:46 PM
  #1  
Member
Thread Starter
 
Join Date: Dec 2008
Location: Ellensburg, WA
Posts: 50
Default '74 rx3 tach not working.

The other day I went to start my '74 rx3 with a '82 12a in it (so its got electronic coil ignition) and it started up, then blew the ignition fuse. I replaced the fuse, started the car again, the tachometer worked for about a second, then went down to 0 and stayed there but the car was still running. There's no specific fuse for the tach, but I'm guessing it would be on the "guages" fuse and all the guages are working. The tach flicks up just a tad whenever i turn the key to the on/off position, which i think shows it has power, and I'm obviously getting power to the coils since it's running, and tach is attached to negative post of the trailing coil, which is also indicating it has power, yet the tach stays at 0. Does anyone have any ideas?
Maxtanner1 is offline  
Old 06-05-2012, 06:24 AM
  #2  
Fabricator
 
Join Date: Jan 2004
Location: Central Ohio (Hebron) Zephyrhills Fla.
Posts: 1,321
Default Re: '74 rx3 tach not working.

Originally Posted by Maxtanner1 View Post
The other day I went to start my '74 rx3 with a '82 12a in it (so its got electronic coil ignition) and it started up, then blew the ignition fuse. I replaced the fuse, started the car again, the tachometer worked for about a second, then went down to 0 and stayed there but the car was still running. There's no specific fuse for the tach, but I'm guessing it would be on the "guages" fuse and all the guages are working. The tach flicks up just a tad whenever i turn the key to the on/off position, which i think shows it has power, and I'm obviously getting power to the coils since it's running, and tach is attached to negative post of the trailing coil, which is also indicating it has power, yet the tach stays at 0. Does anyone have any ideas?
The tach died and that blew the fuse. Now the circuit that failed is open and the new fuse powered up the coils again. Try a different tach. They are not very reliable.

Check to see that you are getting spark to the trailing plugs.

Lynn E. Hanover
Lynn E. Hanover is offline  
Old 06-18-2013, 05:42 PM
  #3  
Junior Member
 
Join Date: Oct 2007
Location: Stratford,Ct
Posts: 25
Default Re: '74 rx3 tach not working.

Originally Posted by Lynn E. Hanover View Post
The tach died and that blew the fuse. Now the circuit that failed is open and the new fuse powered up the coils again. Try a different tach. They are not very reliable.

Check to see that you are getting spark to the trailing plugs.

Lynn E. Hanover
Hi Lynn, I know this a old posting but I am having the some issue. My car is a 73 Rx3 I install a Msd box with 3 coils , 2 for leading,1 for trailing but I don't know what wire is for the tach. HELP!
carlosmazda is offline  
Old 08-25-2013, 10:08 AM
  #4  
Fabricator
 
Join Date: Jan 2004
Location: Central Ohio (Hebron) Zephyrhills Fla.
Posts: 1,321
Default Re: '74 rx3 tach not working.

Originally Posted by carlosmazda View Post
Hi Lynn, I know this a old posting but I am having the some issue. My car is a 73 Rx3 I install a Msd box with 3 coils , 2 for leading,1 for trailing but I don't know what wire is for the tach. HELP!
The MSDs have a tach connetion. It is a resesed male spade connector on the side of the box.

It drives most Tachs just fine. This may not be the case for all tachs however.

The instructions in the box with a new MSD have most of the combinations covered. Also there is a tech phone number at Autotronics for such questions.

Lynn E. Hanover
Lynn E. Hanover is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rotary crew
1st Generation Specific
4
02-16-2008 05:44 PM
greengold
1st Generation Specific
12
04-20-2006 11:01 PM
okisil80
1st Generation Specific
13
02-19-2006 11:07 AM
Cheers!
2nd Generation Specific
8
06-27-2004 12:33 AM
rotogod
3rd Generation Specific
0
06-29-2003 12:51 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: '74 rx3 tach not working.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.