Single Turbo Discussion Area for discussing single turbo RX-7's.

Has Anyone Ever Seen 500rwhp On Pump Gas?

Old 02-03-2004, 02:15 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Jan 2002
Location: Birmingham, AL
Posts: 844
Default

I'm wondering if anyone has made or seen someone make 500rwhp+ on pump gas with a streetported engine with NO water/alc inj, ect.



If so do you have any idea what type turbo they were running?



T-70, T-72, T-76? Ptrim? Qtrim? turbine a/r?



Have any idea what rpm they were hitting 17psi at or what rpm they started making some power?



Thanks for any info,

STEPHEN
SPOautos is offline  
Old 02-03-2004, 04:03 PM
  #2  
Senior Member
 
Join Date: Feb 2002
Location: Frederick MD
Posts: 6,331
Default

I *think* Jason from the rx7store did it. I could be wrong though.. He's running some upgraded T78 and a huge streetport.
9BASE3 is offline  
Old 02-03-2004, 04:28 PM
  #3  
Senior Member
 
Join Date: May 2002
Location: Okinawa, Japan
Posts: 4,928
Default

I think IGY did with his bridgeport T67(turbonetics, not greddy)
jspecracer7 is offline  
Old 02-03-2004, 04:38 PM
  #4  
Senior Member
 
Join Date: Nov 2001
Location: NJ
Posts: 4,981
Default

Vosko was damn close, but car got killed before he could tune more, and turn up the boost
turbovr6 is offline  
Old 02-03-2004, 04:58 PM
  #5  
Senior Member
 
Join Date: Jul 2001
Location: Tulsa, OK
Posts: 3,346
Default

There was that one guy from Australia over on the club that hit 475rwhp with a t04s. Seems like he was in the 17-18psi range.
94touring is offline  
Old 02-03-2004, 05:31 PM
  #6  
Senior Member
Thread Starter
 
Join Date: Jan 2002
Location: Birmingham, AL
Posts: 844
Default

Originally Posted by 9BASE3' date='Feb 3 2004, 10:03 PM
I *think* Jason from the rx7store did it. I could be wrong though.. He's running some upgraded T78 and a huge streetport.
Yea, he was running race gas @ 19psi.



Does anyone around here have a T72 or T76 with some dyno charts I can check out???



STEPHEN
SPOautos is offline  
Old 02-03-2004, 05:39 PM
  #7  
IGY
Senior Member
 
Join Date: Dec 2001
Location: Okinawa Japan at McDonalds
Posts: 472
Default

I was running a 1/2 bridge at 18-19 psi with a 67-1 AR 1.15 p trim. I was using 89 octane gas and no water injection. I never put it on the dyno, but I can guarantee it was over 500rwhp. When you are embarassing 6 and 700hp gtr's you really don't care what the dyno says.
IGY is offline  
Old 02-03-2004, 05:44 PM
  #8  
Senior Member
 
Join Date: Jun 2002
Location: WA
Posts: 1,312
Default

19 psi on 89 octane? lol.. insane!! :thumbs:
sidewinderx7 is offline  
Old 02-03-2004, 06:00 PM
  #9  
Senior Member
 
Join Date: Dec 2002
Location: Misawa Japan
Posts: 826
Default

BP all day
toddp31 is offline  
Old 02-03-2004, 06:22 PM
  #10  
Super Moderator
 
Join Date: Jul 2001
Location: NJ
Posts: 17,839
Default

18-20 psi on my setup with it tuned on pump gas would have been over 500rwhp........
vosko is offline  

Thread Tools
Search this Thread
Quick Reply: Has Anyone Ever Seen 500rwhp On Pump Gas?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.