Single Turbo Discussion Area for discussing single turbo RX-7's.

Almost Finished Pics

Old 08-29-2005, 05:39 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

Here are some almost finished pics. The cars vaccume hose system is going to be in stainless, but i just put it together with silicon because i want to drive it...



I tried to take a vid of it running but ran out of memory. The camera really does it no justice...
rfreeman27 is offline  
Old 08-29-2005, 05:41 PM
  #2  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

rfreeman27 is offline  
Old 08-29-2005, 05:46 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

rfreeman27 is offline  
Old 08-29-2005, 05:50 PM
  #4  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

if you look closely in the first pic you can tell that it is running ;0
rfreeman27 is offline  
Old 08-29-2005, 06:01 PM
  #5  
Senior Member
 
Join Date: Jan 2003
Location: union, new jersey
Posts: 8,079
Default

never realized that the water pump housing was so big til saw your none water stock water pump setup
FikseRxSeven is offline  
Old 08-29-2005, 06:31 PM
  #6  
Senior Member
 
Join Date: Jul 2002
Location: Portland, OR
Posts: 2,467
Default

OMG! WOW i'm speechless!
89 Rag is offline  
Old 08-29-2005, 07:52 PM
  #7  
Senior Member
 
Join Date: Aug 2002
Posts: 502
Default

Really nice! Have any pics of the waterpump?
ccarlisi is offline  
Old 08-29-2005, 09:01 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

This is the best I could do without the car on the lift.



From the bottom
rfreeman27 is offline  
Old 08-29-2005, 09:04 PM
  #9  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

it was leaking coolant very slowly from the holes where the long bolts are threaded. The pump mounts to the flange from the other side. that is why there are some random bolts in there...



bottom looking from drivers side
rfreeman27 is offline  
Old 08-29-2005, 09:07 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

in the engine bay



I dug out my video camera. Ill take some vids of street tunning to 20lbs tomorrow incar



I like how i have this nice waterpump setup, and then the little hose to the right with the bolt blocking it...lol
rfreeman27 is offline  

Thread Tools
Search this Thread
Quick Reply: Almost Finished Pics


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.