RX-8 Discussion Discussion on Mazda's newest rotary powered vehicle.

Engine Troubles?

Old 06-17-2014, 06:51 PM
  #11  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

I havent had time to mess with it actually... Busy with school/work/etc... But I am considering just throwing a fuel pump in it to see what happens. Another person I talked to suggested the coolent temp sensor, which after some thought, if it were to malfunction the ecu may not realize how hot the engine is getting and not operate the fans correctly... Bit of a long shot but I can get a sensor for $12 so may as well try it...
alt3r3go is offline  
Old 06-18-2014, 09:52 AM
  #12  
Junior Member
 
Join Date: Jun 2014
Posts: 2
Default Re: Engine Troubles?

Thank you for you reply. I suppose the ignition is being guilty at my Rx8. Because I got higher octane rated fuel and "voila" the car runs almost perfectly. I got advices from an Rx8 specialist that I'd just found. He said that the original coils are in an unpleasant place and can be overheated easily causing malfunction. The main thing to fix it with new coils supported by a console. I ordered already (Yukon coils, plus new wires, spark plugs) hope will be o.k. I will notice you if this totally solves the trouble...
svoros is offline  
Old 06-18-2014, 10:37 AM
  #13  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

Ignition was one of the first things I tried, with no avail, maybe it will work for you. I have noticed with the summer the car is running better (not perfect), perhaps something has changed in the gasoline...
alt3r3go is offline  
Old 06-18-2014, 10:47 AM
  #14  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

Forgot to note, one point it did make an interesting sound once. To me, can't confirm, but to be it did sound like it back fired through the intake. Now I'm not sure thats what happened, but it did sound different than previously... I think I may be looking for some kind of pre-ignition problem...
alt3r3go is offline  
Old 09-03-2014, 01:48 PM
  #15  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

Sorry guys never got back to you. I personally don't like when these threads just end with no resolution, not very helpful to people using the search cause you don't know if it ever got fixed... Anyways, I ended up putting this off and put $$ into my 4x4, just recently started looking at this again. I read an article awhile back about rx8 fuel pump failure modes, and it sounded exactly like the problem I'm seeing, that is fuel starvation after long freeway drives or after 60k miles on the pump, I'm way pass that. So I tested the flow of the fuel pump, and it good for the first five minutes or so, but then it got really, really slow. Shop manual says it should pump erratically after 10 minutes but erratic and slow are not the same. So the article recommended the walbro 255lph pump as a upgrade to fix the issue, which is actually cheaper then buying a new oem pump. I will order parts Friday hopefully that's the end of that.
alt3r3go is offline  
Old 09-10-2014, 10:20 PM
  #16  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

New pumps in, I'll report back in a week, that should give the car enough time to adjust. Was sitting at a long term fuel trim of 18.8%, hopefully that come back down under 10.

Link back to the article: http://www.rx8club.com/series-i-majo...-modes-176491/
alt3r3go is offline  
Old 09-15-2014, 04:31 PM
  #17  
Junior Member
Thread Starter
 
Join Date: Apr 2014
Posts: 11
Default Re: Engine Troubles?

Alright guys, been almost a week and I'm happy to report a major improvement in performance. The high rpm noise appears to be completely gone, and idle has stabilized quite a bit. At idle it still sounds a bit rough, I think I'll first try changing the oil and running some cleaner through it. After that though I'm not sure what else I could replace at this point, I know I do have one noisy idler pulley but other than that I have only injectors to look at. I'll update if I come up with anything else.
alt3r3go is offline  
Old 09-15-2014, 07:56 PM
  #18  
Member
 
Join Date: Apr 2014
Location: Melbourne Australia
Posts: 92
Default Re: Engine Troubles?

Good to see you got it fixed
WJMRTY is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
eyecandy
3rd Generation Specific
22
06-08-2005 10:25 PM
BigTurbo74
Insert BS here
22
11-10-2002 04:53 PM
SilentRX
2nd Generation Specific
1
10-21-2002 10:36 PM
rota-re
2nd Generation Specific
1
02-17-2002 10:11 AM
Bacon
Front Desk
3
02-02-2002 07:45 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Engine Troubles?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.