2nd Generation Specific 1986-1992 Discussion

What exactly is going on?

Old 10-27-2005, 10:53 AM
  #1  
Member
Thread Starter
 
Join Date: Jun 2005
Location: Rochester, NY
Posts: 79
Default

Well, since it's happened I haven't done it since because it doesn't seem like a good thing. When I reach max boost the car seems to backfire, or sputter a little bit, then the boost kicks in again...over and over. I got pretty scared at first, but I assume as long as I don't keep on doing this it shouldn't be a problem. Remember I am a newby and still have to learn a lot about these cars. Anyways, I was wondering what the cause of this is and how I can fix it. Is it because I haven't installed my FCD yet? Or because I still need to port my the wastegate? I'm really not too sure that it's either of these things, but I've done some research all over this thing and I think those are the 2 most likely things I can think of. So far I've only put a new exhaust system in it, a "high-flow" cat., and 3" downpipe to 2.5" for the rest. I'm sure you guys know exactly what's going on. Help a brother out. Thanks.
sublimike is offline  
Old 10-27-2005, 11:06 AM
  #2  
Senior Member
 
Join Date: Jan 2005
Location: Albuquerque, NM
Posts: 163
Default

It really sounds like you may be hitting fuel cut. You will get an axtrememly lean condition when that happens and when the fuel does kick back on it could be causing that backfire. Its bot good for the motor. Install that FCD I sold you!!!!! It literally only takes about a minute!!!!!
RE87FC is offline  
Old 10-27-2005, 11:24 AM
  #3  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Originally Posted by RE87FC' post='773186' date='Oct 27 2005, 09:06 AM

It really sounds like you may be hitting fuel cut. You will get an axtrememly lean condition when that happens and when the fuel does kick back on it could be causing that backfire. Its bot good for the motor. Install that FCD I sold you!!!!! It literally only takes about a minute!!!!!


yep. i put mine in in the rb parking lot
j9fd3s is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jungle
ECU Discussions
13
06-04-2003 12:30 PM
Red Suns
2nd Generation Specific
10
04-24-2003 11:16 AM
MazdaMike
3rd Generation Specific
19
02-04-2003 04:23 PM
Rob x-7
Insert BS here
9
10-23-2002 11:41 PM
LilFatCrazyWop
2nd Generation Specific
16
05-21-2002 12:34 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: What exactly is going on?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.