2nd Generation Specific 1986-1992 Discussion

Walbro Fuel Pump Is Sometimes Loud

Old 04-26-2004, 09:18 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

A month ago we installed a walbro 255lph hp pump in a t2. We noticed sometimes its really really loud and sometimes not. He has rewired the fuel pump and is running stock efi. We just changed the plugs and noticed that the car is running lean @ 10psi... They are white and so is the o2 sensor. So is this pump taking a ****? Its new.........
1Revvin7 is offline  
Old 04-26-2004, 09:28 PM
  #2  
Senior Member
 
Join Date: Apr 2004
Location: Highways of the Midwest
Posts: 896
Default

You notice any certain conditions when its loud?
psyclo is offline  
Old 04-27-2004, 09:59 AM
  #3  
Senior Member
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Usually whinning of the pump is indicative of an upcoming failure, no?
ColinRX7 is offline  
Old 04-27-2004, 10:57 AM
  #4  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

mine is like that too, sometimes its quiet, sometimes loud. how loud? mine isnt really all that loud ever, it does vary though
j9fd3s is offline  
Old 04-27-2004, 11:54 AM
  #5  
Senior Member
Thread Starter
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Originally Posted by j9fd3s' date='Apr 27 2004, 10:57 AM
mine is like that too, sometimes its quiet, sometimes loud. how loud? mine isnt really all that loud ever, it does vary though
At idle you can hear it over the exhaust( dp/mp) from outside the car...
1Revvin7 is offline  
Old 04-27-2004, 12:24 PM
  #6  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Originally Posted by 1Revvin7' date='Apr 27 2004, 08:54 AM
At idle you can hear it over the exhaust( dp/mp) from outside the car...
higgis was so loud he could hear it over the open dp....



mine is audible at idle, sometimes
j9fd3s is offline  
Old 04-27-2004, 01:24 PM
  #7  
Senior Member
 
Join Date: Nov 2002
Location: Honolulu, Hawaii USA
Posts: 925
Default

Did you use the "kit" that uses the lower rubber isolator as stock?

Did you clamp the Walbro to the metal bracket? This can cause lots of noise.





-Ted
RETed is offline  
Old 04-27-2004, 04:30 PM
  #8  
Senior Member
 
Join Date: Dec 2002
Location: Wayne, NJ
Posts: 4,838
Default

i can hear mine but only if i listen for it with the radio off. the exhaust covers it up most the time.



we'll see how it is once the second one is in there.



kevin.
teknics is offline  
Old 04-27-2004, 05:48 PM
  #9  
Senior Member
 
Join Date: Nov 2002
Location: Lynwood WA
Posts: 275
Default

You can usualy hear mine at idol in and out of the car..............thats with 3"DP 3"test pipe and CS catback lol
ECKO1980 is offline  
Old 04-27-2004, 08:19 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Originally Posted by RETed' date='Apr 27 2004, 01:24 PM
Did you use the "kit" that uses the lower rubber isolator as stock?

Did you clamp the Walbro to the metal bracket? This can cause lots of noise.





-Ted
I will have him check into those...
1Revvin7 is offline  

Thread Tools
Search this Thread
Quick Reply: Walbro Fuel Pump Is Sometimes Loud


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.