2nd Generation Specific 1986-1992 Discussion

Wacko Rev Buzzer

Old 03-14-2004, 12:39 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Jul 2003
Posts: 1,882
Default

All of a sudden my rev buzzer just comes on when im driving.Sometimes when I turn it goes off and also when I hit big enough bumps.Most of the time it goes for a minute or so before it shuts up or if I shake the wheel left and then right really quick it will shut up.The fluid dummy light comes on during this time but all fluids were checked 2 weeks ago.



ehh
4RotorRocket is offline  
Old 03-14-2004, 12:43 AM
  #2  
Senior Member
 
Join Date: Mar 2002
Location: Ky
Posts: 2,725
Default

that buzzer works for everything in the car, low fluid ect. Check the different sensors and recheck all the fluids
Seppuku is offline  
Old 03-14-2004, 01:35 AM
  #3  
Senior Member
 
Join Date: Mar 2003
Location: Florida
Posts: 127
Default

Maybe the water in the rad is shifting around, somtimes dropping below the sensor level.
HIMNI RACING is offline  
Old 03-14-2004, 09:13 AM
  #4  
Super Moderator
 
Join Date: Feb 2002
Location: Amityville, New York
Posts: 12,289
Default

dont disconnect it, check the fluids again especially

whatever one the light is coming on for.
Rob x-7 is offline  
Old 03-14-2004, 09:48 AM
  #5  
Senior Member
 
Join Date: Jun 2003
Location: Panama City, Florida
Posts: 224
Default

Mine used to do that to, and i would get so pissed off. But when i painted my interior i had changed all the switched on the dasch with my Turbo II and it has not done it since. I think it is right there on the turn signal switch.
Houstonderk is offline  
Old 03-14-2004, 11:27 AM
  #6  
Senior Member
Thread Starter
 
Join Date: Jul 2003
Posts: 1,882
Default

Originally Posted by Rob x-7' date='Mar 14 2004, 10:13 AM
dont disconnect it, check the fluids again especially

whatever one the light is coming on for.
yeah I will at least hold off on that part until I check everything over again
4RotorRocket is offline  
Old 03-14-2004, 12:43 PM
  #7  
Senior Member
 
Join Date: Mar 2002
Location: Ky
Posts: 2,725
Default

I wouldnt ever take it out if you have a problem fix it. Dont take some ghetto shortcut.
Seppuku is offline  
Old 03-14-2004, 12:49 PM
  #8  
Member
 
Join Date: Jan 2003
Posts: 75
Default

sometimes air bubbles get stuck in there, and block the sensor from having water around it. that happens when u either flush the coolant, or if you refill it somestimes. So bleed it and it may help your problem. It may not go away the very second you bleed it but it will stop soon after.
JspecRX7 is offline  
Old 03-14-2004, 01:49 PM
  #9  
Senior Member
Thread Starter
 
Join Date: Jul 2003
Posts: 1,882
Default

Originally Posted by Seppuku' date='Mar 14 2004, 01:43 PM
I wouldnt ever take it out if you have a problem fix it. Dont take some ghetto shortcut.
don't worry no ghetto shortcuts for me thanks for the help guys
4RotorRocket is offline  
Old 03-15-2004, 06:56 AM
  #10  
Senior Member
 
Join Date: Jun 2002
Location: WA
Posts: 1,312
Default

i took my buzzer out does that mean im ghetto?!



**** got wacky on me, i had to listen to it on a drive from san francisco to seattle ... almost the whole way. And yes, everything was good with the car. I just got tired of hearing the buzzer when i hit redline, etc..



the buzzer is located on the back of the guage cluster. Its white, and is a little speaker.
sidewinderx7 is offline  

Thread Tools
Search this Thread
Quick Reply: Wacko Rev Buzzer


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.