2nd Generation Specific 1986-1992 Discussion

Thinking About Buyin A 1987 Turbo 2

Old 03-21-2004, 01:17 AM
  #1  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

hey guys. well my cousin has 1987 rx-7 turbo 2 that he is selling. it has 90,000 miles on it but i think he said somethin about it being rebuilt but i am not sure. heres the catch tho, the turbo does not spool past 3500 rpm. he tells me all it needs is new secondary injectors but i am kinda skeptical. does anyone know if it would be wise for me to dump 3000 grand for this car or if i should keep lookin for other rx-7's? well thanks for the help guys, i really appreciate it.
eclipseaudio1530 is offline  
Old 03-21-2004, 01:26 AM
  #2  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

He either has an exhaust leak between the motor, a bad turbo or the turbo or low compression. Low compression = rebuild... So have a compression test done then offer him $2k.
1Revvin7 is offline  
Old 03-21-2004, 04:55 PM
  #3  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

do think its that serious? is there any possibilty its the injectors?
eclipseaudio1530 is offline  
Old 03-21-2004, 05:05 PM
  #4  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Originally Posted by eclipseaudio1530' date='Mar 21 2004, 05:55 PM
do think its that serious? is there any possibilty its the injectors?
Looks like I might have read that too fast. Does the car not run past 3000 rpms?
1Revvin7 is offline  
Old 03-21-2004, 05:21 PM
  #5  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

yeah, it runs really good but the turbo totally drops off at 3500 rpm and doesnt spool after that.
eclipseaudio1530 is offline  
Old 03-21-2004, 05:45 PM
  #6  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

it still runs there just isnt any boost.
eclipseaudio1530 is offline  
Old 03-21-2004, 06:46 PM
  #7  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Originally Posted by eclipseaudio1530' date='Mar 21 2004, 06:45 PM
it still runs there just isnt any boost.
Thats strange. That has nothing to do with the injectors. If it was the injectors not coming on it would be like hitting a brick wall when boost came on.
1Revvin7 is offline  
Old 03-21-2004, 07:03 PM
  #8  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

his other theory was that the cats were clogged and making the engine not able to create enough boost.
eclipseaudio1530 is offline  
Old 03-21-2004, 07:06 PM
  #9  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Originally Posted by eclipseaudio1530' date='Mar 21 2004, 08:03 PM
his other theory was that the cats were clogged and making the engine not able to create enough boost.
Very possible.
1Revvin7 is offline  
Old 03-21-2004, 07:08 PM
  #10  
Member
Thread Starter
 
Join Date: Mar 2004
Posts: 84
Default

damn, i really like this car A LOT but i am not to good with piston engines let alone rotaries. i dont know if i should take the risk of buying it.
eclipseaudio1530 is offline  

Thread Tools
Search this Thread
Quick Reply: Thinking About Buyin A 1987 Turbo 2


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.