2nd Generation Specific 1986-1992 Discussion

Rpm Idle

Old 02-09-2004, 01:34 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Feb 2004
Location: Peoria, AZ
Posts: 1,505
Default

My 88TII idles at 2000 almost 2500RPM and i was wondering if that is normal because my car does have high milage and I dont know if thats normal for rx7s and i notices most cars idle at 1500 or less, thx alot
drunkin_idiot is offline  
Old 02-09-2004, 01:54 PM
  #2  
Senior Member
 
Join Date: Nov 2001
Location: Ames, IA
Posts: 4,766
Default

There's a thermal wax pellet in the throttle body that causes the high idle. If it's malfunctioning or if there's a vacuum leak, you may get a high idle. If you want, you can do the TB mod and get rid of it.
UniqueTII is offline  
Old 02-09-2004, 01:58 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Feb 2004
Location: Peoria, AZ
Posts: 1,505
Default

so is it normal to idle at 2000............. or is that a malfunction?
drunkin_idiot is offline  
Old 02-09-2004, 02:15 PM
  #4  
Senior Member
 
Join Date: Nov 2001
Location: Ames, IA
Posts: 4,766
Default

Normal idle is around 750.
UniqueTII is offline  
Old 02-09-2004, 02:34 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Feb 2004
Location: Peoria, AZ
Posts: 1,505
Default

lmao... ok cool and thanks.
drunkin_idiot is offline  
Old 02-09-2004, 04:06 PM
  #6  
Senior Member
 
Join Date: Jul 2003
Posts: 1,882
Default

Originally Posted by drunkin_idiot' date='Feb 9 2004, 11:34 AM
My 88TII idles at 2000 almost 2500RPM and i was wondering if that is normal because my car does have high milage and I dont know if thats normal for rx7s and i notices most cars idle at 1500 or less, thx alot
Is it a ported motor?Adjust the idel sensor.



Check for vaccum leaks like UniqueTII said though first.



Welcome to Nopistons
4RotorRocket is offline  
Old 02-09-2004, 05:25 PM
  #7  
Senior Member
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Originally Posted by 4RotorRocket' date='Feb 9 2004, 02:06 PM
Is it a ported motor?Adjust the idel sensor.
Idle sensor? WTF are you talking about..
ColinRX7 is offline  
Old 02-09-2004, 08:48 PM
  #8  
Senior Member
 
Join Date: Nov 2002
Location: Honolulu, Hawaii USA
Posts: 925
Default

Is this a stock TB or a modded one?

If it's modded, did you pull the fast idle cam?

If it's stock, it's most likely the cold start system. The thermo pellet is not functioning, and it's either dead or the coolant passages are plugged (more likely).







-Ted
RETed is offline  
Old 02-09-2004, 08:53 PM
  #9  
Senior Member
 
Join Date: Mar 2003
Location: Seattle, WA
Posts: 105
Default

I think by idle sensor he meant throttle position sensor (TPS), just for the drunken_idiot's clarification.
Redwood is offline  
Old 02-09-2004, 10:49 PM
  #10  
Senior Member
 
Join Date: Jul 2003
Posts: 1,882
Default

Originally Posted by Redwood' date='Feb 9 2004, 06:53 PM
I think by idle sensor he meant throttle position sensor (TPS), just for the drunken_idiot's clarification.
sorry my bad
4RotorRocket is offline  

Thread Tools
Search this Thread
Quick Reply: Rpm Idle


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.