2nd Generation Specific 1986-1992 Discussion

Pulled My Motor Today

Old 03-06-2004, 08:44 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

I have 45 pictures, heres a couple..



I grabbed a work truck and picked up an engine hoist at my friend Dave's house,

and I finally got the motor out.



Took about an hour, going slowly.. All preliminary work was done, just unbolt the

engine/tranny mounts, and chain it up..
Attached Thumbnails Pulled My Motor Today-100_0062.jpg  
ColinRX7 is offline  
Old 03-06-2004, 08:47 PM
  #2  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Also when I pulled the driveshaft out yesterday, I noticed some wear (from

debris?) in the machined end that goes in the tranny..



Curious if I should be concerned about it or not..
Attached Thumbnails Pulled My Motor Today-shaftmch.jpg  
ColinRX7 is offline  
Old 03-06-2004, 09:20 PM
  #3  
Senior Member
 
Join Date: Dec 2002
Location: QUEENS NYC
Posts: 1,687
Default

nice more pics
ROTARYROCKET7 is offline  
Old 03-06-2004, 09:26 PM
  #4  
Senior Member
 
Join Date: Dec 2003
Location: Mississippi
Posts: 464
Default

heehee, pulling that engine is a bitch the first time. but it speeds up later. and it looks a tad different than my s5. heh
venomrx7 is offline  
Old 03-06-2004, 09:41 PM
  #5  
Senior Member
 
Join Date: Mar 2003
Location: ATX
Posts: 1,534
Default

Your engine bay looks like it has been on fire.
Nemesis is offline  
Old 03-06-2004, 09:47 PM
  #6  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

This is the first engine pull I've ever done on an RX7. It went very smoothly and

easily.



The engine bay used to be red, but someone did a shitty black paintjob to the whole car, and the engine bay paint they did was even shittier. And it's dusty from sitting for the past 5 months during winter..
ColinRX7 is offline  
Old 03-06-2004, 09:52 PM
  #7  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

This is the only forum I'm not afraid to post the before-pictures before the after-pictures.



Next few weeks, you'll see pics of a glossy black engine bay, that's the reason the motor came out.
ColinRX7 is offline  
Old 03-06-2004, 09:59 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Another



The black is overspray of them "painting the engine bay" by the old owner..
Attached Thumbnails Pulled My Motor Today-100_0066.jpg  
ColinRX7 is offline  
Old 03-06-2004, 10:16 PM
  #9  
Senior Member
 
Join Date: Sep 2003
Location: south jersey...VINELAND
Posts: 343
Default

Originally Posted by Nemesis' date='Mar 6 2004, 07:41 PM
Your engine bay looks like it has been on fire.
nice start'em up!!! hahaha
bart3lz is offline  
Old 03-06-2004, 10:19 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Oct 2003
Location: Canada
Posts: 3,502
Default

Originally Posted by ColinRX7' date='Mar 6 2004, 07:59 PM
The black is overspray of them "painting the engine bay" by the old owner..
That's what I said
ColinRX7 is offline  

Thread Tools
Search this Thread
Quick Reply: Pulled My Motor Today


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.