2nd Generation Specific 1986-1992 Discussion

Ok...so It Wasnt The Cats After All

Old 01-27-2004, 08:52 PM
  #1  
Senior Member
Thread Starter
 
Join Date: May 2003
Posts: 1,784
Default

I finally get my downpipe in, its the thunderfab dp/mp combo. And I still have stock catback but anyways my car is running again. I take it out go driving around gun it and i still hav the 5k stutter. Its not nearly as bad as it used to be and heres how it goes.



stock cats stock catback - car just wont go past 5k rpm at all.



gutted cats stock catback - car slowly slowly goes past 5k rpms but its smooth



3inch dp stock catback - car goes past 5k but it sputters for a second and my car does really small and short backfires.



And i checked all my grounds and they're fine in fact theyre aftermarket so i doubt its the grounds. I'm at a loss. I doubt i'm hitting fuel cut too becuase i was having this problem when i still had functional cats.
Dramon_Killer is offline  
Old 01-27-2004, 09:37 PM
  #2  
Senior Member
 
Join Date: Apr 2003
Location: Schofield Barracks, HI
Posts: 2,259
Default

i still think its your fuel injectors like i told you a while ago
FrestyleFC3S is offline  
Old 01-27-2004, 11:35 PM
  #3  
Senior Member
Thread Starter
 
Join Date: May 2003
Posts: 1,784
Default

Cmon, any clue?
Dramon_Killer is offline  
Old 01-27-2004, 11:43 PM
  #4  
Senior Member
 
Join Date: Apr 2003
Location: Schofield Barracks, HI
Posts: 2,259
Default

Originally Posted by Dramon_Killer' date='Jan 28 2004, 01:35 AM
Cmon, any clue?
what can you NOT read?







FUEL INJECTORS



theyre dirty....clean them
FrestyleFC3S is offline  
Old 01-28-2004, 12:04 AM
  #5  
Senior Member
 
Join Date: Jul 2002
Posts: 2,315
Default

i had a problem with my n/a, it would stutter in higher rpm because when i took off wiring harness my injector clips on the secondary rail the fastener broke and they would occasionally fall off. maybe you should check that too..
BigTurbo74 is offline  
Old 01-28-2004, 12:09 AM
  #6  
Senior Member
Thread Starter
 
Join Date: May 2003
Posts: 1,784
Default

The clips are broken off but they are still fairly secure on the fuel rail i'm pretty sure. I just put them back on and made sure they were fine.
Dramon_Killer is offline  
Old 01-28-2004, 12:13 AM
  #7  
Member
 
Join Date: Nov 2003
Posts: 33
Default

Run some SeaFoam or Marvel Mystery Oil in your tank. Or something.
1971ChevelleSSV8 is offline  
Old 01-28-2004, 12:41 AM
  #8  
Senior Member
 
Join Date: Apr 2003
Location: Schofield Barracks, HI
Posts: 2,259
Default

Originally Posted by Dramon_Killer' date='Jan 28 2004, 02:09 AM
The clips are broken off but they are still fairly secure on the fuel rail i'm pretty sure. I just put them back on and made sure they were fine.
well duh







so do this: get new clips and wire those in, now theyre fixed.....and while theyre off, get your injectors cleaned
FrestyleFC3S is offline  
Old 01-28-2004, 01:00 AM
  #9  
Senior Member
 
Join Date: Nov 2002
Posts: 3,108
Default

Why did you change your exhaust? Why would your exhaust fix a car that did not want to rev past 5000?



I think you need to rethink your trouble shooting. I would nail down fuel injectors, but with only primaries firing you should still be able to rev pretty high even with boost.



Does it rev past 5000 in neutral?



There are two things to check:

Fuel and Spark



Do what freestyle said, check the injecotrs, if those check out ok (replace you damn clips, there is nothing worse then having iffy **** when you are trying to find problems and u din't want iffy things to let go when u are trying to strive for performance).



Then Check spark. Check timming, check ignitors, are the coils ok?



I doubt your exhaust really helped
Cheers! is offline  
Old 01-28-2004, 08:37 AM
  #10  
Senior Member
 
Join Date: Dec 2002
Location: fredneck MD
Posts: 4,107
Default

Get some new plugs while you are in there!
rfreeman27 is offline  

Thread Tools
Search this Thread
Quick Reply: Ok...so It Wasnt The Cats After All


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.