2nd Generation Specific 1986-1992 Discussion

Oil Pressure Gauge dead

Old 10-24-2010, 01:04 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2010
Posts: 17
Default

So The gauge was working fine before the car was taken apart. During removal the capacitor on the tranny was broken. I didn't bother to fix this because of a time crunch. I got it running and for about a week it read normally, then for a few weeks the pressure read at the top of the gauge, like above the top mark. Then one day it went all the way down and doesn't respond anymore. Any ideas on what I'm in for before I start probing? Chances I killed the sender are probably high. Anyone want to take a stab at the outcome of diag on this?
confab is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rx7fcfc
2nd Generation Specific
1
05-31-2010 11:02 PM
rx7fcfc
2nd Generation Specific
3
05-28-2010 09:53 AM
camrann
2nd Generation Specific
1
07-01-2005 06:08 PM
pengaru
Insert BS here
5
11-28-2002 12:41 PM
runnermatt
2nd Generation Specific
1
08-24-2001 06:40 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Oil Pressure Gauge dead


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.