No start cold, hot and warn starts fine. - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

2nd Generation Specific 1986-1992 Discussion

No start cold, hot and warn starts fine.

Reply

 
 
 
Old 10-14-2007, 08:22 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: reno nv
Posts: 20
Default

For the year that I have owned my t2 it's been fun, not many problems and most of the ones that I have had to fix were simple. Now, however, it will start fine warm or even hot, but will be a pain in the *** to start if its cold (about as cold as when frost starts to form on the glass) and I have to crank it about 7 to 8 times at about 40 seconds a shot then let the starter cool back off before it starts. After it starts it runs like a champ no hesitation and it revs up fine, drives fine, but just a pain in the *** to start. After a lot of searching it looks like I am going to change out the coolant temperature probe. Is there any thing else that it might be? I would love the help, as I want to drive it back and forth to work and not need a starter in another 2 weeks, I'm just glad its not my DD. Thanks in advance for the help.
bluemunkey1820 is offline  
Reply With Quote
Old 10-15-2007, 01:18 AM
  #2  
Senior Member
 
Join Date: Nov 2002
Location: Colorado Springs
Posts: 1,679
Default

do you have a check engine light?



if not, your t2's just a touch low on compression, nothing to worry about they all suck at cold starting
Apex13B is offline  
Reply With Quote
Old 10-15-2007, 11:23 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2006
Location: reno nv
Posts: 20
Default

Originally Posted by Apex13B' post='885438' date='Oct 14 2007, 10:18 PM
do you have a check engine light?



if not, your t2's just a touch low on compression, nothing to worry about they all suck at cold starting
its a s4 so no check engine light
bluemunkey1820 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
thegreenebean21
2nd Generation Specific
0
05-10-2009 03:04 PM
MrSparkle
2nd Generation Specific
7
01-03-2004 03:24 PM
j9fd3s
Insert BS here
33
06-26-2003 03:14 PM
LannyRX7
2nd Generation Specific
10
06-23-2003 01:51 AM
fritzfry
3rd Generation Specific
13
05-20-2003 01:42 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: No start cold, hot and warn starts fine.


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.