2nd Generation Specific 1986-1992 Discussion

My Stock Boost Gauge Stopped Working!

Old 01-22-2004, 01:50 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 11
Default

A few days ago I installed a BOV on my car, and my brother was sitting in the car and nottice that the STOCK BOOST GAUGE wasn't getting any reading. We replaced the PRESSURE SENSOR, but it still wouldn't get any reading. Do you guys know what could have caused my boost gauge to stop working?
Turbo2FC3S is offline  
Old 01-22-2004, 01:52 PM
  #2  
Senior Member
 
Join Date: Nov 2001
Location: Ames, IA
Posts: 4,766
Default

Vacuum lines.
UniqueTII is offline  
Old 01-22-2004, 01:54 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 11
Default

well, yesterday I installed an after-market HKS boost gauge, and that one worked fine.
Turbo2FC3S is offline  
Old 01-22-2004, 01:56 PM
  #4  
Senior Member
 
Join Date: Nov 2001
Location: Ames, IA
Posts: 4,766
Default

I've had times when my stock gauge stopped working and my aftermarket one didn't. It all depends on where the vacuum leak is.
UniqueTII is offline  
Old 01-22-2004, 01:58 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 11
Default

i'll check all the vacum hoses to see if that's the problem. If there is no leak, what else do you think could be wrong with it, other than the gauge itself going bad.
Turbo2FC3S is offline  
Old 01-23-2004, 01:01 AM
  #6  
Member
 
Join Date: Jul 2003
Location: Walnut Creek, CA
Posts: 90
Default

you say it's not working, like it's a bad thing..... you have an Aftermarket one anyway,,,,, right,,,,, if not this would be a good reason to get one````
bacca is offline  
Old 01-23-2004, 01:52 AM
  #7  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 11
Default

It's because i heard and my bro has also heard that it's bad if your stock boost gauge stops working, because it tells the engine when it's boosing or something like that. With an aftermarket gauge, the engine doesn't even know it's there, it's as if you didn't have another gauge. Oh yeah, i just drove the car a few minutes ago and it started working again. I wonder what made it stop working.
Turbo2FC3S is offline  
Old 01-23-2004, 12:01 PM
  #8  
Senior Member
 
Join Date: Apr 2002
Location: NASA/JSC - Clear Lake, TX
Posts: 870
Default

good point, the ECU might go into safe mode and retard timing and adjust other things to prevent detonation. although i heard the ECU doesn't use boost pressure to calculate fuel (uses MAF instead, which will change at boost chages). even so, my boost line popped off once at 1/8 track, and it greatly effected my HP.
RX7Aggie is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Kuz7
3rd Generation Specific
0
06-26-2004 02:34 PM
AMRAAM4
RX-7 & RX-8 Parts For Sale & Wanted
0
01-01-2004 03:22 PM
BAdAzZV8
RX-7 & RX-8 Parts For Sale & Wanted
0
10-02-2002 07:46 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: My Stock Boost Gauge Stopped Working!


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.