My First Post - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

2nd Generation Specific 1986-1992 Discussion

My First Post

Reply

 
 
 
Old 03-27-2004, 10:30 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Posts: 2
Default

Well this is my first post, I just bought a 87 N/A about 5 days ago. It needs alittle work but I got it for a decent price. The only problems on it is that it is to low and the exhaust is not all that great either. I really need to get the suspension fixed because the owner before lowered it by heating the springs, I think (it bounces too much). I also have trouble starting it occasionally, it just turns off after you turn the key, I'm not sure whats wrong since I am new to rotary. Thanks in advance.
zero is offline  
Reply With Quote
Old 03-27-2004, 11:51 AM
  #2  
Senior Member
 
Join Date: May 2003
Location: Aurora, IL
Posts: 1,291
Default

well take some time in here and search and research cause there are plenty of guyz than can awnser you questions.. i for one had a 87 t2 and know that they are legendary for not starting to well.. as far as exhaust and supspension there is plenty of aftermarket support out for these cars (no matter what some people in here might tell you... i could be worse... like aftermarket for a 3rd gen prelude)
MazdaEnthused is offline  
Reply With Quote
Old 03-27-2004, 10:43 PM
  #3  
Senior Member
 
Join Date: Sep 2003
Location: south jersey...VINELAND
Posts: 343
Default

that turning of thing is prolly just a vaccumm leak.....
bart3lz is offline  
Reply With Quote
Old 03-28-2004, 10:40 PM
  #4  
Senior Member
 
Join Date: Aug 2002
Location: One hour north of chicago (Mundelein to be exact)
Posts: 811
Default

The bouncing thing is probably worn out struts which happens a lot with lowering springs.
rmaiersg is offline  
Reply With Quote
Old 03-28-2004, 11:01 PM
  #5  
Senior Member
 
Join Date: Jul 2002
Posts: 2,315
Default

Originally Posted by MazdaEnthused' date='Mar 27 2004, 10:51 AM
well take some time in here and search and research cause there are plenty of guyz than can awnser you questions.. i for one had a 87 t2 and know that they are legendary for not starting to well.. as far as exhaust and supspension there is plenty of aftermarket support out for these cars (no matter what some people in here might tell you... i could be worse... like aftermarket for a 3rd gen prelude)
you had starting problems with your old engine?
BigTurbo74 is offline  
Reply With Quote
Old 03-29-2004, 01:23 PM
  #6  
Senior Member
 
Join Date: May 2003
Location: Aurora, IL
Posts: 1,291
Default

no... once i flooded it trying to drift in the mall parking lot and stalled it and quickly learned how to get around it the fast way... which was pulling the EGI fuse or what ever and cranked it over put it back in and it ALWAYS fired right back up....
MazdaEnthused is offline  
Reply With Quote
Old 03-30-2004, 08:50 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Mar 2004
Posts: 2
Default

Thanks for everyones help, I'll will probably pull the EGI fuse to see if that helps any.
zero is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
SAfreak
Meet and Greet
4
08-02-2014 09:48 PM
FikseRxSeven
Insert BS here
14
05-15-2004 08:10 PM
ROTARYROCKET7
2nd Generation Specific
8
02-03-2003 01:30 AM
700hpNA4rotor
Insert BS here
11
01-13-2003 04:51 PM
1Revvin7
Front Desk
4
01-08-2002 02:25 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: My First Post


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.