Fuel Pump Not Working - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

2nd Generation Specific 1986-1992 Discussion

Fuel Pump Not Working

Reply

 
 
 
Old 04-02-2004, 11:09 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 25
Default

I have an 86 automatic and the trans is removed as it is blown. The motor is good after a month of mmo soaking. When I turn the ignition on the fuel pump does not kick on as it should. I should hear it click or rattle alittle bit as soon as the power is turned on. Could there be a connection disconnected down by where the tranny was?
ydeardorff is offline  
Reply With Quote
Old 04-02-2004, 11:13 PM
  #2  
Senior Member
 
Join Date: Oct 2002
Posts: 472
Default

Im not big on electrical stuff, especially with the FC. Get a volt meter and try to run down the problem. I do know that the fuel filter is located to the left of the tranny on the driverside.
rotary speedster is offline  
Reply With Quote
Old 04-03-2004, 03:11 AM
  #3  
Senior Member
 
Join Date: Dec 2001
Posts: 147
Default

Do you mean crank the engine or just turn the key to the ON position? Because the fuel pump won't turn on unless the engine is cranking or the engine is running.
neevosh is offline  
Reply With Quote
Old 04-03-2004, 02:34 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Jan 2004
Posts: 25
Default

Yeah I meant with the key turned to on. Most cars fuel pumps will pressurize the line when they are turned to the on position. So we will see.
ydeardorff is offline  
Reply With Quote
Old 04-03-2004, 03:22 PM
  #5  
Senior Member
 
Join Date: Mar 2002
Location: Ky
Posts: 2,725
Default

It doesnt come on unless the car is being started or on. If you want it on with the key there is a jumper on the passenger side strut tower its yellow.
Seppuku is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Veritas
3rd Generation Specific
3
12-29-2006 06:32 PM
ROTARYROCKET7
RX-7 & RX-8 Parts For Sale & Wanted
1
12-13-2006 02:46 PM
rotorizit
ECU Discussions
2
08-27-2005 04:18 PM
Lothema
2nd Generation Specific
2
04-28-2005 01:00 AM
87turbollrex
2nd Generation Specific
5
11-15-2002 12:28 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Fuel Pump Not Working


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.