2nd Generation Specific 1986-1992 Discussion

Fuel Pump...

Old 03-14-2004, 02:49 PM
  #1  
Member
Thread Starter
 
Join Date: Oct 2003
Location: Tulsa, OK
Posts: 68
Default

I just finished building my 87 gxl, S5 rotors, intake, housings.. S4 sensors, and the rest of the car, and also a fairly large street port. The problem is this.. My car totally acts like a Turbo II. The power under 3 is fairly weak, and it comes on strong AFTER the secondaries come on line. There is a lag in acceleration between 3.5 and 4K rpm, but not a miss like an ungrounded afm/pressure sensor likes to cause. The exhaust smells very rich, although there is no black smoke behind me when I get on it. The only thing that seems out of limits is the fuel pump. It whines pretty bad, and the frequency of the "whine" goes up and down. I don't have a fuel pressure tester, nor will I for about a week, so just wondering what you guys think.

Thanks!

Jim
threcixty is offline  
Old 03-14-2004, 05:21 PM
  #2  
Member
Thread Starter
 
Join Date: Oct 2003
Location: Tulsa, OK
Posts: 68
Default

BTW.. the "whine" that I refer to is from the fuel pump, not the engine.
threcixty is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
memoavina
3rd Generation Specific
2
08-16-2011 02:05 PM
mazdadude7
RX-7 & RX-8 Parts For Sale & Wanted
0
08-17-2007 02:09 PM
drewrey2004
Performance Mods
4
03-12-2007 06:54 PM
ROTARYROCKET7
RX-7 & RX-8 Parts For Sale & Wanted
1
12-13-2006 01:46 PM
87turbollrex
2nd Generation Specific
5
11-14-2002 11:28 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Fuel Pump...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.