2nd Generation Specific 1986-1992 Discussion

Detonation Problem

Old 12-21-2003, 01:34 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2003
Posts: 21
Default

I've got a 90 rx7 TII and just put in a ported motor, had it all tuned perfectly but then when it started to get cold out. Car leaned out just at one rpm only, right around 4600. I have 860 cc secondary injectors, Safc II and walbro fuel pump. I've been told to try maybe a hotter spark plug and see if that helps. I've tryed to mess around with the fuel curve over and over. I just can't seem to get that little ping to go away. Any suggestions would be appreciated alot. Thanks- Darin
NeedToSellMyCar is offline  
Old 12-21-2003, 03:59 PM
  #2  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

I'm assuming you are running the highest octane gas possible, right?
1Revvin7 is offline  
Old 12-21-2003, 05:27 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Dec 2003
Posts: 21
Default

yes, i always run premium. Never had this problem till i came home from school one weekend and was colder by like 30 degrees and haven't been able to fix since.
NeedToSellMyCar is offline  
Old 12-22-2003, 10:01 AM
  #4  
Senior Member
 
Join Date: Nov 2002
Location: Central KY
Posts: 292
Default

Originally Posted by NeedToSellMyCar' date='Dec 21 2003, 11:34 AM
I've got a 90 rx7 TII and just put in a ported motor, had it all tuned perfectly but then when it started to get cold out. Car leaned out just at one rpm only, right around 4600. I have 860 cc secondary injectors, Safc II and walbro fuel pump. I've been told to try maybe a hotter spark plug and see if that helps. I've tryed to mess around with the fuel curve over and over. I just can't seem to get that little ping to go away. Any suggestions would be appreciated alot. Thanks- Darin
Other than retarding the timing a degree or two... (way too simple and way too cheap LOL)



Since it is only happening at that one RPM section, it is kinda hard to justify water injection. However, AQUAMIST makes great water injectors



Aquamist UK home



There are fully mappable models and there are pre-programmed (unmappable) models) It is just another item to tune but you may be better off with the AQUAMIST 2S. It is fully mappable at incremental RPM. For example you do not have to have the same flow at 2k as you do at 4k so you can really zero in to a trouble range. i.e. if you are detonating at 4500-4750 RPM you can raise the ml/min flow rate in only this range.



Aquamist are also methanol safe (as an anti freeze). This is really opening a can of worms cause tuners argue about the best methanol mix. This will only be a problem if you are in subzero climates or just want to run a methanol mix. Normal mix is around 20% methanol as an antifreeze. However, this may draw attention come race time cause methanol has an octane rating of 130 if I am not mistaken. If you race seriously check your regs to see if this is permissible. However, just water alone is awesome as it has one of the highest if not the highest latent heat of evaporation of a liquid. Which means it is going to stabilize combustion a lot and pull away a serious amount of heat from the combustion chamber. Even though water has no octane rating, by proxy it will boost your fuels octane rating.



It also goes with out saying (but), if you tune with water injection, make FOR CERTAIN you do not run out of water!!!



There have been a few discussions on this forum on water injection, and there seems to be a great debate weather to plumb before or after your IC. That you will have to decide for yourself



Good luck man, keep us posted
twstdmtl is offline  
Old 12-23-2003, 03:12 AM
  #5  
Senior Member
 
Join Date: Jan 2002
Location: CT
Posts: 1,345
Default

how do u know it pings?
kahren is offline  
Old 12-23-2003, 06:40 PM
  #6  
Senior Member
 
Join Date: Oct 2003
Location: I don't really exist ...
Posts: 486
Default

so you're saying that everything before AND after 4600 RPM is fine?

what engine management are you running?

i'll assume that you've tried to get the secondaries to come in a little earlier?
diabolical1 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
FikseRxSeven
Insert BS here
13
10-11-2003 02:51 AM
1revin7
2nd Generation Specific
4
09-12-2003 10:57 PM
Tom Czupta
3rd Generation Specific
15
09-07-2003 03:40 PM
rotarychainsaw
2nd Generation Specific
16
12-05-2002 10:04 PM
hackz
Performance Mods
4
04-15-2002 12:35 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Detonation Problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.