2nd Generation Specific 1986-1992 Discussion

All Idiot Lights On

Old 01-17-2006, 04:11 PM
  #1  
Administrator
Thread Starter
 
Join Date: Jul 2001
Location: Stuart, FL
Posts: 24,412
Default

Wut the hell? This is a first, anyone have any idea wut the hell could cause that?
phinsup is offline  
Old 01-17-2006, 05:06 PM
  #2  
Senior Member
 
Join Date: Dec 2002
Location: Wayne, NJ
Posts: 4,838
Default

your key is in the on position without the engine running.



that could cause it.



kevin.
teknics is offline  
Old 01-17-2006, 05:14 PM
  #3  
Senior Member
 
Join Date: Mar 2004
Location: A2, MI
Posts: 453
Default

ha! I was gonna say the same thing... my brother did that on his car and came running inside to get me to see what was wrong... he just hadnt started the car.
toplessFC3Sman is offline  
Old 01-17-2006, 05:17 PM
  #4  
Senior Member
 
Join Date: May 2005
Posts: 277
Default

broken alt belt ?
Nospig is offline  
Old 01-17-2006, 05:36 PM
  #5  
Senior Member
 
Join Date: Jan 2005
Location: Greenwood AR
Posts: 831
Default

Mine didnt do this for a long time, now it does it, nothing seems to be wrong.
fc3s4utnv is offline  
Old 01-17-2006, 06:24 PM
  #6  
Administrator
Thread Starter
 
Join Date: Jul 2001
Location: Stuart, FL
Posts: 24,412
Default

Originally Posted by Nospig' post='794710' date='Jan 17 2006, 06:17 PM
broken alt belt ?


Yup, the light bulb went on on the way to look at the car, i had remembered the same thing happening with my se, just took a few to sink in.



The ******* that borrowed my car told me he tightened the belt, the thing was WAY to tight.
phinsup is offline  
Old 01-17-2006, 07:36 PM
  #7  
Senior Member
 
Join Date: Nov 2005
Location: CHARLOTTE,NC.
Posts: 390
Default

what about the alternator check the charge
1979rx7 is offline  
Old 01-18-2006, 12:18 PM
  #8  
Senior Member
 
Join Date: Mar 2004
Location: A2, MI
Posts: 453
Default

you might even need to check the bearings in the alternator, make sure there isnt any play since it was overtightened
toplessFC3Sman is offline  
Old 01-18-2006, 02:54 PM
  #9  
Administrator
Thread Starter
 
Join Date: Jul 2001
Location: Stuart, FL
Posts: 24,412
Default

it was prolly driven only 15 or 20 miles with it being that tight, so i should be ok!
phinsup is offline  
Old 06-21-2006, 11:40 PM
  #10  
Member
 
Join Date: May 2006
Location: Canada, Alberta
Posts: 76
Default

Yupp my alternator belt went, and all lights on!
Tomoya is offline  

Thread Tools
Search this Thread
Quick Reply: All Idiot Lights On


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.