fuel sending unit - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

1st Generation Specific 1979-1985 Discussion

fuel sending unit

Reply

 
 
 
Old 03-27-2009, 06:18 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2009
Location: Kansas City, Missouri
Posts: 22
Default

I just bought a 1982 Mazda RX7 and the fuel gadge does not work. What could the problem be? If it is the fuel sending unit where is it located at on this car.I also read a post that it could be a fuss that need replaced, where would that be. I sure could use expert advice from you guy's. This is my 1st mazda i like it a lot
g.l.audio is offline  
Reply With Quote
Old 03-28-2009, 12:33 AM
  #2  
Senior Member
 
Join Date: Dec 2008
Location: Folsom, CA
Posts: 737
Default

well have you checked to see if its even connected behind the dash
RicerJ is offline  
Reply With Quote
Old 03-28-2009, 07:23 AM
  #3  
Super Moderator
 
Join Date: Apr 2002
Location: VA
Posts: 2,533
Default

I've moved this thread to the first gen forum. Hopefully, some of the very knowledgeable members here can help you find the solution.
1988RedT2 is offline  
Reply With Quote
Old 03-28-2009, 11:38 AM
  #4  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

sending unit is really easy to get to, if you look in the left rear wheel well, its right behind a plastic shield
j9fd3s is offline  
Reply With Quote
Old 03-30-2009, 07:22 PM
  #5  
Senior Member
 
Join Date: Dec 2005
Location: Oregon
Posts: 407
Default

I have had this problem before. Sometimes The variable resistor sending unit will get dirty over time. you could get off easy with just running a bottle or two of a good fuel system cleaner through it.. or you might have to remove it to clean it. you can check the unit with a multi meter.. use the ohm setting..



And of course check the wiring while you have the multi meter out.
RE_TurboFB is offline  
Reply With Quote
Old 01-14-2010, 09:05 PM
  #6  
Junior Member
 
Join Date: Jan 2010
Location: California
Posts: 1
Default

I have a 1982 rx7 and my fuel gauge did not work when i got it. I replaced my fuel float/sending unit about a week ago and my fuel gauge works great. There is a good chance that is your problem its an easy fix if you are patient.
RotaryMat66 is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
itsbrokeagain
RX-7 & RX-8 Parts For Sale & Wanted
1
11-13-2006 05:44 PM
SBMotors
RX-7 & RX-8 Parts For Sale & Wanted
0
03-16-2006 06:29 PM
FikseRxSeven
Performance Mods
2
05-12-2005 08:32 PM
cps87rx7se
2nd Generation Specific
1
02-02-2004 07:49 AM
RX-Midget
3rd Generation Specific
1
12-14-2002 03:53 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread