Single Turbo Discussion Area for discussing single turbo RX-7's.

Just Finished Single Install... Not Good...

Old 02-24-2005, 07:28 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2002
Posts: 27
Default

well i had a apex rx6 kit lying around, so i figured i would install it and see how it was. my car was running perfectly fine 2 months ago before i started doing the install. the car has been sitting for the winter and i started the single about 2 weeks ago. anyway got it done today and i fired it up.... blowing some thick oil and has 0 power. it doesnt want to idle at all. it smells of fuel and oil pretty bad. seems to me like the motor is blown but i dont understand how. i started the car before the install and no problems. did the install and now it runs like ****. any ideas of what it could be? maybe something i forgot to connect?
smg944 is offline  
Old 02-24-2005, 07:45 PM
  #2  
DUB
Senior Member
 
Join Date: Jun 2003
Posts: 568
Default

Holy cow man, that one hard problem to diagnose over the net...



Sounds like it could be a bad turbo...blowing tons of oil.



what ECU?



Do a compression test to see about the motor.
DUB is offline  
Old 02-24-2005, 07:54 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Nov 2002
Posts: 27
Default

will do a compression test tomorrow. it seems more like the motor then the turbo just by the way it runs, idles, and sounds. unless there is an oil vacuum i forgot to connect. i still have the rats nest in, because i thought i might go back to the twins.



btw. the ecu is a power fc tuned for the turbo and 1200cc injectors.



also.. i checked the intercooler pipes and there was no oil so thats another reason i think its not the turbo.
smg944 is offline  
Old 02-24-2005, 10:56 PM
  #4  
Senior Member
 
Join Date: Jul 2001
Location: Tulsa, OK
Posts: 3,346
Default

Did you eliminate the rats nest and add the proper block off plates ect... Does the ecu have the proper map? A lot of variables and unlikely the engine is blown if all you did was crank it up.
94touring is offline  
Old 02-25-2005, 12:04 AM
  #5  
Senior Member
 
Join Date: Jan 2003
Location: union, new jersey
Posts: 8,079
Default

my guess is you'r flooding your engine with those 1200cc injectors... you probably dont have the injectors set for stock... double check that.



and make sure everything is blocked off and capped properly
FikseRxSeven is offline  
Old 02-25-2005, 01:31 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Nov 2002
Posts: 27
Default

what do you mean by the injectors set for stock? i installed the turbo kit, ecu, and injectors at the same time. the ecu was set for the turbo and 1200cc injectors.
smg944 is offline  
Old 02-25-2005, 06:42 AM
  #7  
Senior Member
 
Join Date: Sep 2002
Location: Alexandria Va
Posts: 657
Default

can you get a video of it running or cranking. That would help
Fe3Boost is offline  
Old 02-25-2005, 07:41 AM
  #8  
amp
Super Moderator
 
amp's Avatar
 
Join Date: Jan 2002
Location: New Jersey
Posts: 3,928
Default

were there any issues with the turbo prior to install..
amp is offline  
Old 02-25-2005, 08:41 AM
  #9  
Senior Member
 
Join Date: Mar 2003
Location: Sunny South Florida :)
Posts: 1,963
Default

what size oil feed line are you running to the turbo? did the kit come with a pill?
mazdadrifter is offline  
Old 02-25-2005, 09:24 AM
  #10  
Junior Member
Thread Starter
 
Join Date: Nov 2002
Posts: 27
Default

no problems with the turbo that i know of. no shaft play or anything either.



i am using the oil feed line that came with the kit. i dont know if there are any pills in it...



i will try to get a vid. ill see if my buddy has something i can use.
smg944 is offline  

Thread Tools
Search this Thread
Quick Reply: Just Finished Single Install... Not Good...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.