2nd Generation Specific 1986-1992 Discussion

Please Help, Turbo Ii's Inconsistency

Old 12-17-2003, 04:53 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Joplin, MO
Posts: 603
Thumbs up

I was just wondering if anyone could help me out with this weird problem regardless of temperature, the Turbo II's seem to run different on a daily basis. Most of the time it runs great but some days it seems more like it lacking 50 hp, even with the same boost on an aftermarket gauge.



The mods are a Street Ported Engine, Racing Beat Full Turbo back exhaust, cone air filter, HKS blow off valve, The boost is retarded with a controller through the blow off valve to keep it under the shut off limit for the ecu.



Please help, and thanks in advance.
'79rx7 is offline  
Old 12-17-2003, 06:48 PM
  #2  
Senior Member
 
Join Date: Mar 2002
Posts: 288
Default

Originally Posted by '79rx7' date='Dec 17 2003, 10:53 PM
The boost is retarded with a controller through the blow off valve to keep it under the shut off limit for the ecu.
are you trying to say you are bleeding off boost from the IC pipe to lower it???



that is totatly not good. you just have a huge vac leak under boost. I'm surpised it runs at full thottrol.
Scott 89t2 is offline  
Old 12-20-2003, 08:12 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Joplin, MO
Posts: 603
Default

It's not a vacuum leak cause it's only open under full boost it's just a mechanical boost controller, trust me that is not the problem or even part of it. Beside this problem has occured on more then one of the turbo II's that I've owned.
'79rx7 is offline  
Old 12-20-2003, 09:13 PM
  #4  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Does that gadget you have vent back to the intake? If not then your venting metered air.



Or you could be boost spiking into fuel cut.
RONIN FC is offline  
Old 12-21-2003, 10:04 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Joplin, MO
Posts: 603
Default

it's vented to the atmosphere, you can't vent back to the intake it would defeat the purpose of retarding the boost. Sometimes though it does cut out at 6500 rpm.
'79rx7 is offline  
Old 12-22-2003, 04:16 AM
  #6  
Senior Member
 
Join Date: Mar 2002
Posts: 288
Default

dude you are totaly screwing your car up with that......



fix that first. then see if the other problem is still there.



I'm guessing that when the car runs fine that vent is closed. and as soon as it opens the car runs like crap.



it's going to run super *** rich when it vents boost out because the ecu thinks all that air went into the engine.



also you are spinning the crap outa your turbo. which will cause much more wear on it and cause the intake temps to go much higher.



if your boost is too high for your likings. there is only 2 things you can do. one is to port the wastegate. and the other is to make your intake or exhuast more restrictive to reduce creep. bleeding off boost is not one of the choices.
Scott 89t2 is offline  
Old 12-22-2003, 11:55 AM
  #7  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Originally Posted by '79rx7' date='Dec 21 2003, 08:04 PM
it's vented to the atmosphere, you can't vent back to the intake it would defeat the purpose of retarding the boost. Sometimes though it does cut out at 6500 rpm.
You cant vent metered air. And when i said intake, i meant pre turbo intake. Thats the way the factory does it.



I agree with Scott, remove that thing, and sell it to someone with a supercharger.
RONIN FC is offline  
Old 01-01-2004, 03:17 AM
  #8  
Senior Member
Thread Starter
 
Join Date: Sep 2002
Location: Joplin, MO
Posts: 603
Default

Thing is, it'll run great some days then other's it won't, and this problem has occured on more than one car, with or without the boost retarded.
'79rx7 is offline  
Old 01-01-2004, 12:13 PM
  #9  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

Originally Posted by '79rx7' date='Jan 1 2004, 01:17 AM
Thing is, it'll run great some days then other's it won't, and this problem has occured on more than one car, with or without the boost retarded.
you may wanna look at the air and coolant temp sensors, they can get intermittant and can do wierd things
j9fd3s is offline  
Old 12-12-2004, 10:38 PM
  #10  
Junior Member
 
Join Date: Jul 2004
Location: Wenatchee, WA
Posts: 14
Default

So you have a boost controller? I have the racing beat full turbo-back exaust system too, it is supposed to raise boost to around 11-12 psi, Do you have a fuel cut -defencer?
Brownsc18 is offline  

Thread Tools
Search this Thread
Quick Reply: Please Help, Turbo Ii's Inconsistency


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.