2nd Generation Specific 1986-1992 Discussion

oil+boost pressure issue

Old 08-24-2011, 01:01 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2011
Location: Toulouse, France
Posts: 7
Default

So for two months now, i have issues with my car.



what happened is that i did my oil+filter change then i tried to remove the emissions system (unsuccessfuly).

Since then when warm, at idle my car is at 1 bar of oil pressure (instead of 2 bar before). Although when i drive the car, i reach the 4 bar correctly as before. I guess the oil pressure regulator in the crankshaft is somehow not working properly. You think it could be that ?



Second point, My turbo is now going from -0.8 bar to 0.5 bar instead of -0.6 to 0.7 bar before. Do you know what could be the cause of that ?

I precise, this reading is with my aftermarket boost gauge has the stock one has never been properly working.



Pleaaaaase help me
Grunswald is offline  
Old 08-24-2011, 03:23 AM
  #2  
Junior Member
Thread Starter
 
Join Date: Aug 2011
Location: Toulouse, France
Posts: 7
Default

This morning i thought about something for the boost pressure... i played a little with air filter (oem). I've tried to remove the dust with a brush and then reinstall it by turning it 180 (not upside down). If it somehow restrict the admission, i suppose it could lead to an increase of the negative pressure and of the max pressure at the same time. I'm thinking about either that or the intercooler that is clogged and also restrict the air debit...
Grunswald is offline  
Old 08-25-2011, 01:52 AM
  #3  
Senior Member
 
Join Date: Dec 2008
Location: Folsom, CA
Posts: 737
Default

what brand gauges you running it might play a bit into whats going on
RicerJ is offline  
Old 08-25-2011, 06:08 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Aug 2011
Location: Toulouse, France
Posts: 7
Default

i got zenky racing ones. but i left the car at the mechanic shop. They didn't have the time to look at it in 4 weeks due to holidays. Although they took the time to mesure the pressures with their tools and everything and they found the same result has the one shown by my gauges.
Grunswald is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rx7fcfc
2nd Generation Specific
1
05-31-2010 11:02 PM
rx7fcfc
2nd Generation Specific
3
05-28-2010 09:53 AM
Dysfnctnl85
Rotary Engine Building, Porting & Swaps
22
11-01-2005 11:41 AM
nopistons94
3rd Generation Specific
24
08-24-2005 11:38 AM
Rotarian 1126
3rd Generation Specific
8
04-14-2004 07:38 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: oil+boost pressure issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.