2nd Generation Specific 1986-1992 Discussion

Few Questions...

Old 12-28-2003, 04:32 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Alright, here we go...



The exhaust, is 2.5, as you can see the main cat is damaged if not complety destroyed. So what are the potential problems of dropping a straight pipe on this bitch?



2nd question



The line that goes to im assuming the wastegate, not the coppery colored piece near the turbo but the silver one closes to the passenger side fender. It has a nut, and a little mechanical arm down the side of it, on the under side near the heat shield. Anyways, the vac line, going from this metal rod that connects to the tip of it, i have it going to the TB connecting to a open vac hole...is that acceptable? im getting really bad boost creep, no boost til like late 3k or early 4k.



I was under the car doing fuel filter change trying to kill this 3-4k hesitation under heavy throttle...im thinking the TB mod is causing it...but i cant be certain....



any help would be appreciated...
Attached Thumbnails Few Questions...-12280003.jpg  
tancred is offline  
Old 12-28-2003, 04:33 PM
  #2  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

And another
Attached Thumbnails Few Questions...-12280001.jpg  
tancred is offline  
Old 12-28-2003, 04:34 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

And another...
Attached Thumbnails Few Questions...-12280002.jpg  
tancred is offline  
Old 12-28-2003, 05:55 PM
  #4  
Senior Member
 
Join Date: Oct 2002
Location: Memphis, Japan
Posts: 427
Default

Well you have got me confused. Is that a picture of the pre car or the main cat??

Either way installing a straight pipe would be easy as long as you don't care about emissions.



As for you second problem of boost creep..... I think you are confused boost creep is when your boost rises above your intended level of boost, for example on some turbo cars such as the 86-88 models the stock boost is normally around .5kilos but after changing the intake and exhaust it will naturally rise to about .7 or so and on some cars in cold weather especially hard pulls in higher gears can make the boost creep all the way to 1kilo or more. The wastegate is set to boost .5 but due to increased flow the wastegate can't dump off the exhaust so boost creeps.

If your boost does not come on until 3-4 grand then you are experiencing a lack of boost and not creep.



The thing I think you are trying to describe is the actuator for the twinscroll valve in the manifold. The hard line coming from that needs to be connected to somewhere on the surge tank/manifold so it reads boost or positive manifold pressure. If you have that then it should be OK. Since you are going to be doing exhaust work maybe you can pull the front pipe and look at the health of your turbine. If it has excessive play or is hard to spin at all you might want to look at replacing it.



Good Luck.
Ranzo is offline  
Old 12-28-2003, 07:25 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Yeah, that was educational, lol...I thought boost creep was when you didnt get boost until later on...well now to answer the question....Main cat...I have no emissions right now...Turbine is fine, pop'd the TID off, it seems to be fine, no excessive play, no rubbing, nothing. Im really getting pissed tho, cuz before i did the tb mod i would get some boost at about 3k, now its not til 4 or later, sometimes as bad as 5. And yes the twin scroll is what im talking about, i have it plugged into my throttle body. to clarify, i was wondering if i need to plug in the twin scroll to the vac source line that is before my turbo after my MAF, it goes up near the oil injectors and then stops, right now i have that line plugged into the TB aswell, so do i need to plug in my twin scroll to that vac source thing...





if thats not specific enough lemme know, i will shoot some pics....





-thankz



Tancred
tancred is offline  
Old 12-28-2003, 07:40 PM
  #6  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

You mean you checked the compressor wheel, the turbine is the exhaust wheel. You probably have a vacuum leak somewhere between the turbo and the afm. If you exhaust manifold/turbing housing was cracked that would also cause slow spool. Low compression would also cause those symptoms.





And I feel like I feel because its cold here where you left me!
1Revvin7 is offline  
Old 12-28-2003, 07:43 PM
  #7  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Yeah, the compressor wheel, i checked it...





Im starting to think that maybe the pos high temp connector im using from my tid to my turbo inlet that KEEEPS melting might be causing this problem...lately ive noticed that it keeps melting and bending in odd shapes...i will drop my dp and look at my "TURBINE" later tonight after dinner...





tancred is offline  
Old 12-28-2003, 08:26 PM
  #8  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Is this the pre cat? The part I circled looks like the wastegate arm, did it break off? That could be your problem.
RONIN FC is offline  
Old 12-28-2003, 09:35 PM
  #9  
Senior Member
Thread Starter
 
Join Date: Nov 2003
Location: Salt Lake City
Posts: 319
Default

Well, thats my dp you have circled....



And currently it has a ratchet mod, 65 to the wheels, i have a ratchet stuck on my dp cuz the bolt threads went to **** and now i have to go get the plasma torch and teach the craftsman son of a bitch tool a lesson...I imagine im going to end up burning a damn hole in the dp if i miss so i am shopping for a new dp aswell, i will look at that part you circled and let you know what i find...







thx for your responses...
tancred is offline  
Old 12-28-2003, 10:14 PM
  #10  
Senior Member
 
Join Date: Oct 2001
Location: Peoria, AZ
Posts: 10,906
Default

Just keep modding the car without a boost gauge and the stock fuel system......
1Revvin7 is offline  

Thread Tools
Search this Thread
Quick Reply: Few Questions...


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.