2nd Generation Specific 1986-1992 Discussion

Coolant Gauge Wiring Questions

Old 12-23-2003, 07:07 PM
  #1  
Senior Member
Thread Starter
 
Join Date: May 2003
Location: Dover DE
Posts: 989
Default

Hey guys, I have a few questions on the wiring of the coolant gauge when installing a Haltech E6K in a S4 T2.



1) What sensor is used?



2) What color and location of wire for coolant gauge in factory dash S4 TII







I am in the middle of wiring up Frestyles car with the E6K and boy have I had my nightmares. First was an old wiring harness diagram in his instruction manual dated 30 Oct 2000. After tearing what was left of my hair out looking for 3 wires the diagrm said I had, I went to haltech's website and found out there was an updated wiring diagram, with the wiring harness I had. Feb 2001. I went through Hitmans site, I went through a few others, I found some really good diagrams on K2RD's site for the CAS, TPS (OEM Style), and the output wiring to the factory coils K2RD wiring schematics



I hate to say this, but I hope I never have to hook one of these systems up ever again, the instruction manual is as clear as mud...
TheCamel is offline  
Old 12-23-2003, 07:13 PM
  #2  
Senior Member
 
Join Date: Mar 2002
Posts: 288
Default

the coolant gauge in the dash has nothing to do with the ECU. it's located under the oil filter. and wired seperatly.



the haltech coolant sensor replaces the stock ECU cooland sensor on the back of the water pump housing.





here is some more reading for you



http://www.1300cc.com/howto/how2/e6k.htm
Scott 89t2 is offline  
Old 12-23-2003, 07:21 PM
  #3  
Senior Member
 
Join Date: Apr 2002
Location: IL
Posts: 2,930
Default

wierd, i didnt have any problems with the wiring.



what scott said is right, any other problems?
pengaru is offline  
Old 12-24-2003, 02:48 AM
  #4  
Senior Member
Thread Starter
 
Join Date: May 2003
Location: Dover DE
Posts: 989
Default

I guess I didn't make my question clear enough. I am looking to hook up the stock coolant gauge in the dash. I have all the Haltech wiring done, with the GM coolant sensor located in the back of the thermostat housing. What I need to know is what do I have to hook into, or use to make the factory gauge cluster work too.
TheCamel is offline  
Old 12-24-2003, 02:48 PM
  #5  
Senior Member
 
Join Date: May 2002
Location: California
Posts: 22,466
Default

the coolant temp guage wire goes from the intrument cluster to the car harness to the engine harness in one of the plugs up by the blower motor. i think its a yellow wire but i'm not 100% sure.



dont feel bad i've forgotten to wire that up twice now
j9fd3s is offline  
Old 12-24-2003, 04:14 PM
  #6  
Senior Member
 
Join Date: Mar 2002
Posts: 288
Default

you shouldn't have to do anything... it should still be hooked up. it has nothing to do with the ECU wiring. the gauge runs off a sensor below the oil filter. and the wire should still be hooked up as it's not in the ECU harness.
Scott 89t2 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
NAFC
2nd Generation Specific
1
02-19-2009 07:17 PM
bebiracer
ECU Discussions
1
01-24-2007 11:13 PM
Baldy
2nd Generation Specific
5
05-07-2005 11:45 AM
turborotor
Performance Mods
6
03-30-2003 07:46 PM
TOFU86
3rd Generation Specific
0
02-19-2003 02:21 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Coolant Gauge Wiring Questions


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.