Car won't start after clutch change - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

2nd Generation Specific 1986-1992 Discussion

Car won't start after clutch change

Reply

 
 
 
Old 08-22-2006, 02:11 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2005
Posts: 116
Default

Before changing the clutch she started up just fine. Now all i get is a clicking noise from the starter. Could it be a ground because i still have one ground wire to plug in that is on top of the tranny. I just can't seem to find where it goes. Every time i have heard a starter click it was shot. What could have made it do this????



Jon
Jonlax is offline  
Reply With Quote
Old 08-22-2006, 04:36 PM
  #2  
Senior Member
 
Join Date: May 2005
Location: San Francisco, CA
Posts: 628
Default

Is the battery charged and making good connection with its cables? Did you hook the starter wires back up correctly?
Stanello is offline  
Reply With Quote
Old 08-22-2006, 04:41 PM
  #3  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Connect that ground.
RONIN FC is offline  
Reply With Quote
Old 08-22-2006, 04:46 PM
  #4  
Senior Member
 
Join Date: Feb 2004
Location: Peoria, AZ
Posts: 1,505
Default

Ya connect the starter ground or it will not start, there is a long *** bolt about 5" long that holds the starter in place, I used that for it.
drunkin_idiot is offline  
Reply With Quote
Old 08-22-2006, 05:39 PM
  #5  
Senior Member
 
Join Date: Apr 2006
Posts: 190
Default

You put your right foot in, you take your right foot out. You put your left foot in, and then you shake it all about... Connect that ground and maybe thats what this problem's all about...er....that's what it's all about?
QuackDamnYou is offline  
Reply With Quote
Old 08-23-2006, 03:37 AM
  #6  
Senior Member
Thread Starter
 
Join Date: Aug 2005
Posts: 116
Default

The starter is grounded but the ground wire that is on the very top of the tranny by the intake manifold is not hooked up. I just cannot find where it plugs into. Anyone know???



Jon
Jonlax is offline  
Reply With Quote
Old 08-23-2006, 11:35 AM
  #7  
Senior Member
 
Join Date: Oct 2003
Location: Boston Ma.
Posts: 1,420
Default

Originally Posted by Jonlax' post='833868' date='Aug 23 2006, 03:37 AM
The starter is grounded but the ground wire that is on the very top of the tranny by the intake manifold is not hooked up. I just cannot find where it plugs into. Anyone know???



Jon
A little tab bolted on the passenger side of the firewall.
RONIN FC is offline  
Reply With Quote
Old 08-23-2006, 01:42 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Aug 2005
Posts: 116
Default

Originally Posted by RONIN FC' post='833901' date='Aug 23 2006, 07:35 AM

A little tab bolted on the passenger side of the firewall.




Thanks!!! i was looking for a wire on the passanger side but all i saw was the injector wires and nothing else. We will see this afternoon when i get home from work!



Jon
Jonlax is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mu5tang
1st Generation Specific
5
01-17-2012 12:01 AM
Rotarydragon
Insert BS here
4
01-11-2005 11:08 AM
MaTT_FoULk
2nd Generation Specific
4
12-20-2002 08:04 PM
FD THREE S
3rd Generation Specific
30
11-08-2002 10:09 AM
gusman
2nd Generation Specific
1
09-21-2002 05:54 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: Car won't start after clutch change


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.