2nd Generation Specific 1986-1992 Discussion

'91 Throttle linkage / TPS problem

Old 01-05-2011, 11:14 AM
  #1  
SiB
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Alberta, canada
Posts: 1
Default

Hey everyone, i'm working on a '91.... the throttle linkage is all wrong and butchered so I am trying to sort it out. Does anyone have a photo (or can take a photo) of the linkages that actuate the TPS sensors. Mine are all binding and giving 3v at idle where it should be 1v. I believe the TPS sensors are correct for the car but the linkage has been modified, its probably from a different year/model.



The car is a '91 turbo RHD.



Thanks
SiB is offline  
Old 09-08-2011, 02:46 PM
  #2  
Junior Member
 
Join Date: Sep 2011
Location: Banning
Posts: 9
Default

Did you still need a photo of the TPS? I have a 91 Convertible and could post one if you need me too. The one on the 91 N/A is a 2 plunger tps the Turbo could be differnt but I am not sure.
johnkean is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mymmeryloss
RX-7 & RX-8 Parts For Sale & Wanted
8
08-11-2010 09:56 PM
idsigloo
RX-7 & RX-8 Parts For Sale & Wanted
0
11-20-2005 06:08 PM
HobbeZ
RX-7 & RX-8 Parts For Sale & Wanted
0
05-24-2005 09:57 AM
HobbeZ
RX-7 & RX-8 Parts For Sale & Wanted
1
01-05-2005 10:56 AM
Wankelteer
2nd Generation Specific
2
04-19-2004 10:22 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Quick Reply: '91 Throttle linkage / TPS problem


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.