1985 RX7 GS will not start - NoPistons -Mazda Rx7 & Rx8 Rotary Forum

1st Generation Specific 1979-1985 Discussion

1985 RX7 GS will not start

Reply

 
 
 
Old 08-07-2018, 07:48 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 1
Default 1985 RX7 GS will not start

Frist let me preface this with I know very little about cars let alone rotary engines.. now for the question I have a 85 RX7 GS with 186K miles, body in very good shape (was CA car in family) anyway it will not start, it will crank and gas is getting to the carb which has been rebuilt. The fuel pump has also just been replaced. I can not find anyone locally that can or will work on it with knowledge of rotary engines. I have had for four years and this is the 2nd summer I have not been able to drive it. All vacuum hoses seem to be in place, spark plugs are clean.. I am at a breakpoint in my decision to keep or sell; 100's to fix or 1000's to fix.. Just don't know what to ask myself or what to look for or at.. any guidance would be much appreciated... here's one more bit of info one time it did fire up and reved to about 3K but soon died (maybe 2 seconds) even with me pumping the gas pedal..
mtv85rx7 is offline  
Reply With Quote
Old 09-27-2018, 11:08 AM
  #2  
Junior Member
 
Join Date: Sep 2018
Posts: 1
Default Re: 1985 RX7 GS will not start

Originally Posted by mtv85rx7 View Post
Frist let me preface this with I know very little about cars let alone rotary engines.. now for the question I have a 85 RX7 GS with 186K miles, body in very good shape (was CA car in family) anyway it will not start, it will crank and gas is getting to the carb which has been rebuilt. The fuel pump has also just been replaced. I can not find anyone locally that can or will work on it with knowledge of rotary engines. I have had for four years and this is the 2nd summer I have not been able to drive it. All vacuum hoses seem to be in place, spark plugs are clean.. I am at a breakpoint in my decision to keep or sell; 100's to fix or 1000's to fix.. Just don't know what to ask myself or what to look for or at.. any guidance would be much appreciated... here's one more bit of info one time it did fire up and reved to about 3K but soon died (maybe 2 seconds) even with me pumping the gas pedal..
Check that you're actually getting spark and that the plug wires are in the correct orientation. Fuel, air, spark. If you have compression it has to be spark.
ungluedflyer is offline  
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dona1326
1st Generation Specific
2
02-24-2012 07:30 AM
MyRX7isbrokenagain
Meet and Greet
6
05-06-2009 12:46 PM
mazda1985
1st Generation Specific
7
04-11-2009 12:43 AM
MyRX7isbrokenagain
2nd Generation Specific
6
04-10-2009 02:39 PM
Srce
Insert BS here
18
05-23-2003 10:12 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread